MacBook Pro 2018 + multitouch gestures on Mojave intermittently going out

Discussion in 'macOS Mojave (10.14)' started by FocusAndEarnIt, Sep 11, 2018.

  1. FocusAndEarnIt macrumors 601

    FocusAndEarnIt

    Joined:
    May 29, 2005
    #1
    Any thoughts on troubleshooting this, guys?

    having an issue with multi-touch gestures sometimes not working intermittently. three finger/four finger actions work, but zoom + two finger swipe to show notification center are not working.

    i am also using better touch tool, but only with settings on the touch bar. turning BTT off doesn't fix it. the only way it is fixed is if i go to settings, manually turn on and off zoom / two finger side swipe and then they start working again. thoughts??
     
  2. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #2
    2-finger taps etc are working intermittently on my macbook pro (and consistently on my macbook). to make things more confusing, about 2 betas ago, both macs were having multitouch issues. seems to be software-related (better than having a hardware issue...)
     
  3. Painter2002 macrumors 65816

    Painter2002

    Joined:
    May 9, 2017
    Location:
    Austin, TX
    #3
    I actually am having some issues on multi-touch gestures on a 2017 MBP wTB as well, on public Mojave beta 10.14 (build 18A384a).

    The issue I am having is that the navigation trackpad gestures (two fingers swiped left or right) to navigate webpages or other app navigation functions intermittently quits working and then starts working again. All the other gestures have seemed to work fine. I have submitted a feedback report to Apple.
     
  4. xryan macrumors newbie

    Joined:
    Oct 9, 2018
    #4
    I just stumbled on this post by chance, but I can at least give a little more insight to this issue from my experience developing the app Multitouch, which provides some similar capabilities to BetterTouchTool.

    It seems to be caused by 3rd party applications that listen to "gesture" type events from an event tap, and users of my app first reported it on High Sierra. I'm guessing that BetterTouchTool must also listen to "gesture" type events. A user reported it on BTT's bug tracking page as well. My users reported intermittent issues with all of the built in two finger gestures - pinch/rotate, and the two finger swipe navigation gestures, but all the other built in mac gestures worked fine. It was quite annoying that the issue persists after closing the app, which makes a user unsure of whether or not the app causes the issue. In the case of my app, it did cause the issue.

    In order to fix the issue in my app, I had to rework a large part of my app to listen to gesture events from Apple's private multitouch framework instead of the publicly available event tap api. That approach has downsides as well, but at least it doesn't affect the built in gestures.

    I don't know if Apple fixed these issues in the actual release of Mojave, or if BetterTouchTool's developer has put in a fix for it on his side, but at least it helps to know a little more about the problem.
     
  5. kevinhooke macrumors newbie

    kevinhooke

    Joined:
    Apr 9, 2017
    Location:
    Davis, California
    #5
    I just had the same issue on Mojave after taking a screenshot with the Grab app - I use 4 finger left/right swipe to switch Spaces desktops and it stopped working after the screenshot. Tried to toggle on/off the gestures in System Preferences but couldn't get them back. Rebooted and everything back to normal.
     
  6. stevemiller macrumors 68000

    Joined:
    Oct 27, 2008
    #6
    having this problem too. I have btt installed so that might be the culprit, which would be unfortunate, because btt is the only thing that makes the Touch Bar tolerable :(
     
  7. WolfSnap macrumors 6502a

    WolfSnap

    Joined:
    Sep 18, 2012
    Location:
    SoCal
    #7
    I've had this issue for a long time -- and it drives me crazy. I have to go into settings and turn off/on the gestures to get them to work again.

    Seems to be more of an issue when I'm using the external magic touchpad 2 vs when I'm only using the touchpad that's part of my MBPtb.

    I had BTT installed, but, it wasn't actually running.. Otherwise, I don't believe I have any apps that are watching gestures -- I'd love to get a fix that isn't just resetting my settings every few days.
     
  8. Fuzzi macrumors member

    Joined:
    Sep 5, 2009
    #8
    BetterTouchTool dev here. I think a bug has been introduced in the event tap handling on macOS Mojave (at least it has gotten worse). I'll try to add a workaround with the next BetterTouchTool version (alpha should be available tomorrow). I'll also file a bug report with Apple.

    If you are experiencing this issue, make sure to not configure the pinch and rotate gestures in BTT for now.
     
  9. Starfia macrumors 6502a

    Starfia

    Joined:
    Apr 11, 2011
    #9
    I'd been suffering from this for ages with my iMac's Magic Trackpad – I finally tried rescinding the Magnet app's accessibility permissions and recovered, if that helps anyone.
     
  10. stevemiller macrumors 68000

    Joined:
    Oct 27, 2008
    #10
    i'm only using btt for touchbar config right now, but i'm still noticing occasional dropouts of multitouch. interestingly it seems to only drop out often when i'm starting my 3d software, so btt might not even be the culprit in my particular case, or its a weird combo of things.
     
  11. cameronwatson macrumors newbie

    Joined:
    Oct 21, 2018
    #11
    FYI: I am having the same issue but do not have BTT installed.
    MacBook Pro (15-inch, 2018)
    2.9 GHz Intel Core i9
    32 GB 2400 MHz DDR4
    Radeon Pro 560X 4096 MB
    Intel UHD Graphics 630 1536 MB
     
  12. dekuji63 macrumors newbie

    Joined:
    Oct 23, 2018
    #12
    MBPro 13" Mid 2014/3Ghz Intel i7/8GB 1600MHz DDR3/Intel Iris 1536 MB

    Watching this thread because since I updated to High Sierra, no 2-finger gestures work on my on-board trackpad or on my Apple BT trackpad. I didn't realize how much I'd grown accustomed to using them until they all went away! Pretty much the only gesture that works besides single pointer is 3-finger swipe down to show open applications. I have tried throwing out preference files, checking/unchecking, restarting, pretty much every suggestion I've run across.

    Weirdly, I can pinch/zoom inside Microsoft Word. That was an unexpected and impractical oddity to discover.

    Had high hopes for Mojave! Maybe after a few updates?
     
  13. RDeckard macrumors regular

    RDeckard

    Joined:
    Sep 23, 2013
    #13
    I had the same issues with Magic Trackpad 2 and built-in trackpad on a 2017 MBP running the GA release of Mojave:
    • No zooming with pinch. This didn’t work with any apps: Safari, Preview, Maps, etc.
    • No rotation with 2 fingers
    It drove me nuts.

    Here's how I fixed it (at least it worked for me):
    • went into the Trackpad preferences in System Preferences
    • Unchecked "Force Click and haptic feedback" in the Point & Click tab
    • Unchecked all options in the Scroll & Zoom tab
    • Closed System Preferences
    • Re-opened Trackpad preferences in System Preferences
    • Re-checked all of the options above
    Then zoom w/pinch and rotation w/2 fingers worked again. I hope it continues to work.
     
  14. Gangsterblast5 macrumors newbie

    Gangsterblast5

    Joined:
    Feb 26, 2018
    #14
    --- Post Merged, Nov 25, 2018 ---
    I had the same problem after updating to Mojave. I had to double tap two fingers to get to mission control and open a new desktop then I can switch between apps. Hope this helps spread the word.
     
  15. Le Rizz macrumors newbie

    Le Rizz

    Joined:
    Nov 30, 2018
    #15

    This is exactly my issue on a mid 2015 MacBook Pro running Mojave 10.14.1 (18B75). I tried restarting, resetting my PRAM and SMC but it's still randomly working and not working across multiple browsers.
     
  16. Pencacatalogue macrumors newbie

    Joined:
    Jul 16, 2014
    #16
    This really worked for me, and I have to say that does work in the 2015 MAcBook Air which doesn't have haptic click
     
  17. jacg macrumors 6502a

    jacg

    Joined:
    Jan 16, 2003
    Location:
    UK
    #17
    Happened to me intermittently since I got my 2016 tbMBP. I have only recently installed BTT so I don't think it is responsible.

    My theory is that it is linked to apps like Splashtop remote desktop or SMART whiteboard tools being used. It's annoying as I will sometime be in an unfamiliar app and not realise the the pinch gesture simply isn't working. It would be useful of there was a script that would toggle it on and off.
     
  18. chaimk macrumors newbie

    Joined:
    Jun 17, 2013
    #18
    FWIW, I just had to toggle it to get the pinch & zoom working again. Weird that it was that one thing though... Thank you Starfia!
     
  19. xryan macrumors newbie

    Joined:
    Oct 9, 2018
    #19
    Appending to my original post:

    Turns out that there's less rhyme or reason to this issue than I had initially thought. Some users experienced issues when my app used the private framework that were fixed when switching to the event tap, and conversely some users experienced issues when using the event tap that were fixed when switching to the private framework. In cases where there were issues that were fixed by changing where the multi-touch data came from, sometimes the user would have to log out and log back in for gestures to be restored.

    Based on other people's comments on this thread and from developing my app, the only conclusion I can make is that Apple's multi-touch framework (private or otherwise), or even Apple's event system is not incredibly stable. At least with 3rd party apps, you should be able to rule them out by making sure they're not running, then log out and log in.

    From the users of my app, I've also noticed that there can be pretty large variances between trackpads, particularly the built-in Macbook Pro ones, despite being from the same model.
     
  20. stevemiller macrumors 68000

    Joined:
    Oct 27, 2008
    #20
    its happening for me almost daily now where it drops out and I have to toggle the trackpad preferences to get it working again.

    also worth noting, for me this has only ever happened on my 2018 MacBook Pro. so potentially add it to the long list of garbage QA apple seems to be allowing to slip by on their newer products.
     
  21. Spartan Weaver macrumors newbie

    Spartan Weaver

    Joined:
    Jan 15, 2019
    Location:
    Colorado
    #21
    Trying this now (disabling Magnet). My quick fix is going to the Trackpad settings and doing the toggle for pinch & zoom (quite annoying). Here's hoping it works!
     
  22. aristidesfl macrumors newbie

    Joined:
    Jun 13, 2013
    #22
    Also using Magnet.app, and having this problem almost since a year, using the same workaround.
    Will stop using the app, and see if the problem persists.
     

Share This Page

21 September 11, 2018