Macbook Pro 3.1 2007 WiFi and left USB problems.

Discussion in 'MacBook Pro' started by imantsng, Jan 12, 2014.

  1. imantsng macrumors newbie

    Joined:
    Jan 12, 2014
    #1
    The WiFi on my macbook pro 3.1 is not working - the mac does not see the wifi card.
    The left USB port is not working too, but provides power (no data).
    The bluetooth is recognized.

    I have tried all the resetting ways and stuff - none of them work.

    I just want to know if my WiFi card is dead, or the part of mac, it's plugged in.
    Or both are dead.
    The audio works.
    Any ideas?
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Sounds like some hardware failures going on with your 2007 MBP. You can try to reinstall a clean install of OSX but I'm rather skeptical that this will solve your problems. I'd say they've failed.

    Live with it, buy a new laptop or attempt a repair by purchasing the logic board and wifi components on ebay.
     
  3. imantsng thread starter macrumors newbie

    Joined:
    Jan 12, 2014
    #3
    It has been reinstaled several times.
    Something is wrong with the hardware ... the question is - which part...
     
  4. imantsng thread starter macrumors newbie

    Joined:
    Jan 12, 2014
    #4
    So ... i bought a new used left i/o board, but the strange problem remains - the power, sound and bluetoth work, but the usb and the wifi do not.

    I assume that the i/o board should be good.
    So can there be a problem with terminal connecting it to the mainboard or say the contacts?

    How should i go about this problem??
     

Share This Page