Macbook Pro 4,1 Won't Idle Sleep

Discussion in 'MacBook' started by Hero321, Feb 24, 2012.

  1. Hero321, Feb 24, 2012
    Last edited: Feb 24, 2012

    Hero321 macrumors newbie

    Joined:
    Feb 5, 2010
    #1
    My macbook pro 4,1 (early 2008 model) will not sleep after being left idle. The screen turns off at the designated time, but the drive remains spinning and any tap on the touchpad brings the computer alive -- this drains my battery substantially when I leave it idle without a power source. Sleep works normally from hitting the power button/closing the lid. It's just the idle, lid open time that it won't sleep.

    Things I have tried:
    Altering the energy settings to every degree
    PRAM reset
    SMC reset
    hard drive permission repair (success)
    Console is not showing anything going on during idle time

    Here is my terminal log for the command "pmset -g assertions,"
    Assertion status system-wide:
    ChargeInhibit 0
    NoDisplaySleepAssertion 0
    CPUBoundAssertion 0
    EnableIdleSleep 1
    NoIdleSleepAssertion 0
    DisableInflow 0
    DisableLowPowerBatteryWarnings 0
    ExternalMedia 0
    No Assertions.

    Here is my terminal log for the command "pmset -g,"
    Active Profiles:
    Battery Power -1*
    AC Power -1
    Currently in use:
    hibernatemode 3
    halfdim 1
    lidwake 1
    acwake 0
    sleep 10
    disksleep 10
    sms 1
    hibernatefile /var/vm/sleepimage
    ttyskeepawake 1
    displaysleep 10


    Other things to note:
    I made a guest account and left the computer idle and had the same issue. However, I booted into safe mode and the hard drive sleeps properly. I'm not sure how to diagnose why safe mode would fix the problem.

    If you can shed any light on this topic, please do. Anything is appreciated, it's driving me nuts! Thank you.
     
  2. Hero321 thread starter macrumors newbie

    Joined:
    Feb 5, 2010
    #3
    Thank you for your reply. Unfortunately, I still have not solved the problem. From one of the links you provided, I did run the command:
    "syslog |grep -i "Wake reason =" with mixed results of:

    Wake reason = EC LID0
    Wake reason = EC LID0 FRWR
    Wake reason = UHC3
    Wake reason = UHC3 FRWR

    The most common instance is of "EC LID0 FRWR". Which the site claims is the lid opening. The other (UHC3), from observation of the time stamps only, I feel indicates that I woke the sleep with spacebar.

    Regardless, I appreciate your input. I would also like to note that I disabled all sharing options as well. I forgot to mention that in original post.
     

Share This Page