Macbook Pro A1181 2007 Battery issues

Adam10541

macrumors newbie
Original poster
Jun 24, 2013
2
0
I'm having a few weird symptoms which I've seen similar threads here but not exactly what I'm having.

Macbook will boot fine from AC but OSX doesn't detect the battery (light stays green) and the battery won't charge. If I remove the AC after the boot process has started the Macbook will run from the battery just fine, but I can't boot without AC attached and I can't charge the battery.

I have tried all the basic troubleshooting, I have confirmed the battery works and the A/C adapter with another working Macbook.

I have replaced the battery connector internally and this battery is a brand new replacement.

For a very brief period after I bought the new battery and reset all the settings everything worked as it should, then just reverted to this and I'm stuck. I'm trying to confirm the correct voltage is coming from the connector but I'm unsure which pins I should be checking with a multimeter.

Any other thoughts/ideas?
 

GGJstudios

macrumors Westmere
May 16, 2008
44,379
704
For battery, power, or charging issues, you might try resetting the SMC. (PRAM/NVRAM has nothing to do with these issues. Resetting it will not help.)

The link below should answer most, if not all, of your battery/charging questions. If you haven't already done so, I highly recommend you take the time to read it.
 

Adam10541

macrumors newbie
Original poster
Jun 24, 2013
2
0
@CGJStudios
I had previously tried this but for giggles tried again and makes no difference. I tried two methods (battery in and battery out) just to make sure. I've also seem most of the other info in my searching around as I've been troubleshooting this for some months on and off.

@G-mo
By good magsafe board do you mean another macbook pro? If you do then yes I do, I have two A1181 models (2006 & 2007 model) and the AC and both batteries work in the 2006 model, neither battery works in the 2007 which I'm having issues with.

My strong suspicion is the circuit board but given that it worked for a brief period initially I'm hoping that it's not.

Edit - I forgot to mention that when booting up and for about 3 minutes afterwards the maglight is red indicating a charge (still no battery detected) then it goes green. If I take the battery out while the macbook is on and switch in the other battery the light goes red again for a few minutes which seems to indicate that it at least knows there is a battery there or not, but just not detecting with the software or charging.
 
Last edited: