Macbook PRO A1286 Battery Problem

Discussion in 'MacBook Pro' started by n00binator, Apr 28, 2010.

  1. n00binator macrumors newbie

    Joined:
    Aug 23, 2008
    #1
    I know this is a very common question but i couldn't find a solution in other threads. I have a Macbook Pro A1286 with the internal battery and about a month ago my little cousin spilled water on it. It stop working but i recently disassembled it, since it had no warranty after the spill, cleaned up the keyboard and the logic board and it started up. Everything works perfectly except from the battery. I doesn't work at all without the power cable on and the led light is always green. In the status bar there is a message saying (Not Charging) and the condition of the battery says Replace Now.
    In the system profiler i get this info:

    Battery Information:

    Model Information:
    Serial Number: W0942AZF977VC
    Manufacturer: SMP
    Device name: bq20z451
    Pack Lot Code: 0000
    PCB Lot Code: 0000
    Firmware Version: 0003
    Hardware Revision: 0003
    Cell Revision: 0100
    Charge Information:
    Charge remaining (mAh): 0
    Fully charged: No
    Charging: No
    Full charge capacity (mAh): 0
    Health Information:
    Cycle count: 117
    Condition: Replace Now
    Battery Installed: Yes
    Amperage (mA): 0
    Voltage (mV): 12264

    System Power Settings:

    AC Power:
    System Sleep Timer (Minutes): 10
    Disk Sleep Timer (Minutes): 10
    Display Sleep Timer (Minutes): 10
    Wake On AC Change: No
    Wake On Clamshell Open: Yes
    Wake On LAN: Yes
    Current Power Source: Yes
    Display Sleep Uses Dim: Yes
    GPUSwitch: 2
    Battery Power:
    System Sleep Timer (Minutes): 10
    Disk Sleep Timer (Minutes): 10
    Display Sleep Timer (Minutes): 2
    Wake On AC Change: No
    Wake On Clamshell Open: Yes
    Display Sleep Uses Dim: Yes
    GPUSwitch: 2
    Reduce Brightness: Yes

    Hardware Configuration:

    UPS Installed: No

    AC Charger Information:

    Connected: Yes
    ID: 0x0100
    Wattage (W): 85
    Revision: 0x0000
    Family: 0x00ba
    Serial Number: 0x009d85a4
    Charging: No

    My question is... Is it just the battery and i only have to buy a new one? Is it the magsafe adaptor, the DC board or the logic board?
    I tried a lot of tricks but if you can help plz reply.
    Thanks a lot and sorry for the usual Thread.
     
  2. n00binator thread starter macrumors newbie

    Joined:
    Aug 23, 2008
  3. JimKirk macrumors 6502

    Joined:
    Oct 6, 2009
  4. Relznuk macrumors 6502

    Relznuk

    Joined:
    Sep 27, 2009
    Location:
    UT, USA
    #4
    +1. If you don't say anything, Apple might replace it for free.
     
  5. zenamic macrumors newbie

    Joined:
    Oct 20, 2010
    #5
    Macbook PRO A1286 Battery Problem

    I also had this problem from a spill on my 15" 2.5 GHz macbook pro. The battery would not charge no matter what I tried. I did ALL the fixes everyone suggested. Replaced the logic board, reset SMC, etc. Nothing worked. I even took my macbook to the apple store and even they could not fix the problem. At this point I just got mad :mad: and took the problem into my own hands. I completely disassembled my macbook. I even took out the 50+ screws for the keyboard. Long story short, after extensive testing I discovered the problem. As I was putting it back together, I noticed that the battery indicator light was not on well I pushed the button. At first I thought it was because the battery had no power. Then I disconnected the battery indicator from the logic board. As shown here "step 16" http://www.ifixit.com/Guide/Repair/...-and-Early-2009-Logic-Board-Replacement/831/6

    And Voila! The battery started to charge. So I figured great I don't really need the battery indicator so I'll just leave it disconnected and I'm home free right? WRONG! Much to my dismay, I later found out that if you leave this disconnected then the mouse and keyboard doesn’t work! Seems everything is wired together and one part depends on another to function.
    So the bottom line is if you are having this problem, check and see if you battery indicator light comes on. If it does not, then chances are you need to have the little Battery Indicator Board replaced. I took me almost 2 weeks to figure this out. I hope this can save some of you a lot of time.
     
  6. n00binator thread starter macrumors newbie

    Joined:
    Aug 23, 2008
    #6
    Thanks a lot but actually it was just the battery. Problem fixed by just replacing it. Admin you can lock this post if you want cayse my problem is solved. Thank you.
     
  7. tcc123 macrumors newbie

    Joined:
    Jan 19, 2012
    #7
    Hello n00binator,

    Exact same thing happened to my Macbook Air 2010 - Water spill, everything works fine other than the battery that says "Not Charging" and "Replace Now".

    Can you please provide a little more detail on how you resolved your problem?

    Was it only the battery that you replaced? And that fixed your problem entirely?

    Where did you get the battery and how much did it cost?

    I greatly appreciate any advice you can offer.

    Thanks!
     
  8. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    This thread is over a year old and n00binator hasn't been on this forum for over a year. Please note the dates of threads you choose to respond to, as outdated threads many times no longer apply.
     

Share This Page