macbook Pro A1286 Not Powering on!

Discussion in 'MacBook Pro' started by brogdan, Apr 6, 2015.

  1. brogdan macrumors newbie

    Joined:
    Apr 6, 2015
    #1
    Hello
    i have a macbook pro A1286, MB no 820-2850-A
    Nothing happens when i press the power butoon., also tried to power it on by the pads on the MB but still noting.
    i tried SMC bypass (10 sec power button pressed, then another 10sec with charger connected) and it powers up, meaning the coollers spin for 1 sec then reboots when the 5v drops down, and so on.

    I noticed that i have no 5V on the L7220. the 5v on this coil only appears for a second then off for another 5-10 sec, and so on.
    i changed the ISL51125, i changed the 2 mosfets Q7225 and Q7220. and still the same.

    Also tried a new bios flash

    any ideea what can it be?
     
  2. DavidBlack macrumors 6502a

    DavidBlack

    Joined:
    Jan 27, 2013
    Location:
    Somewhere In Apple's HQ ;)
  3. Samuelsan2001 macrumors 603

    Joined:
    Oct 24, 2013
    #3
    15.4 inch 2011???

    Your GPU is probably dead (radeongate you may have read about it.) Apple currently have a free repair program for this issue contact them and find out what you need to do in whichever country you are in.

    http://www.apple.com/support/macbookpro-videoissues/
     
  4. brogdan thread starter macrumors newbie

    Joined:
    Apr 6, 2015
    #4
    hello
    mine is a MacBook Pro (15-inch, Mid 2010) and it is not covered by the program and has warranty expired.

    AND mine has a NVIDIA video chip - N11F-GE1-W-A3

    also tried to reheat the GPU, but no signs of life
     
  5. Samuelsan2001 macrumors 603

    Joined:
    Oct 24, 2013
    #5
    That one .......

    ......had a repair program that ran out a couple of years ago.

    I am sorry I can't help you mate. It sounds like a complete logic board failure. So you can buy a second hand board replace it and hope for the best or buy a new computer.
     

Share This Page