macbook pro audio out problem, nuts!

Discussion in 'MacBook Pro' started by karmakvisser, Mar 19, 2008.

  1. karmakvisser macrumors newbie

    Joined:
    Mar 19, 2008
    Location:
    Silver Spring, MD
    #1
    This is the second time I've run into this.
    MacBook Pro 2.16
    10.4.11

    Situation: no sound out from speakers in admin and user account and newly created account. Headphones work, startup chimes work on speakers.

    Go to Sound in Preferences and only shows Digital Out for output. Should show Internal Speakers.

    Ran Diskwarrior and Applejack and zapped pram. Took mac apart and confirmed speakers wired correctly which is verified by the start up chimes being audible on the internal speakers.

    tested all accounts and created new account all with the same results.

    Did search of Google and MacRumor. Found one unaswered post indicating same problem.

    Had same problem with another macbook pro, ran same steps, take apart, confirm wiring setup, Diskwarriored, applejacked and zapped pram and it fixed the problem.

    I'm not sure what else to try. Did check Audio Midi Setup util and it also did not see the internal speakers.

    Any advice would be welcomed.

    regards

    ken
     
  2. stevenfischer20 macrumors newbie

    Joined:
    Apr 29, 2009
    #2
    macbook pro audio out problem, nuts!

    I am experiencing the exact same audio issue, Ken ... very frustrating. Has anyone found a solution?

    Steven


    This is the second time I've run into this.
    MacBook Pro 2.16
    10.4.11

    Situation: no sound out from speakers in admin and user account and newly created account. Headphones work, startup chimes work on speakers.

    Go to Sound in Preferences and only shows Digital Out for output. Should show Internal Speakers.

    Ran Diskwarrior and Applejack and zapped pram. Took mac apart and confirmed speakers wired correctly which is verified by the start up chimes being audible on the internal speakers.

    tested all accounts and created new account all with the same results.

    Did search of Google and MacRumor. Found one unaswered post indicating same problem.

    Had same problem with another macbook pro, ran same steps, take apart, confirm wiring setup, Diskwarriored, applejacked and zapped pram and it fixed the problem.

    I'm not sure what else to try. Did check Audio Midi Setup util and it also did not see the internal speakers.

    Any advice would be welcomed.

    regards

    ken
    __________________
    Ken Visser
    Mac user and abuser since the 80's
    Silver Spring, MD
     
  3. -js- macrumors regular

    -js-

    Joined:
    Jul 30, 2008
    Location:
    Southern California
    #3
    Have you done a hardware test? Put in install disc and restart while holding down the "d" key. Might turn up something, although I doubt it.

    Otherwise, I would suggest reinstalling the OS. At least, that's what I'd try.

    Sorry you're having this problem!
     
  4. areusche macrumors regular

    areusche

    Joined:
    Jun 24, 2008
    #4
    Sounds like the little micro switch in the head phone jack is stuck.

    I've had this problem on a lot of machines before. The trick is to stick a match end or a small flat head screw driver into the head phone jack and wiggle it around for a bit. That will hit the switch and set it so you can play out of your speakers.

    Good luck!
     
  5. Jogging macrumors newbie

    Joined:
    Nov 8, 2009
    #5
    Worked Out

    Sounds like the little micro switch in the head phone jack is stuck.

    I've had this problem on a lot of machines before. The trick is to stick a match end or a small flat head screw driver into the head phone jack and wiggle it around for a bit. That will hit the switch and set it so you can play out of your speakers.

    Good luck!

    Work out fine for me. That was the solution!!
     

Share This Page