MacBook Pro automatically boot into Vista. Help!

Discussion in 'Windows, Linux & Others on the Mac' started by tejota1911, May 4, 2007.

  1. tejota1911 macrumors 6502

    Joined:
    Nov 10, 2006
    #1
    I just installed Vista Home Premium on my MacBook Pro this morning, and Vista has taken over. Somehow it must be set to primary boot OS or something. Instead of me having to hold down "Option" to boot into Vista, it's the other way around. I have to hold down "Option" to boot into Mac OSX. What do I need to do to switch this? I only want to use Vista occasionally not all the time. Thank you in advance.
     
  2. ethernet76 macrumors 6502a

    Joined:
    Jul 15, 2003
    #2
    Hold option right after you press the power key. It'll list all bootable drives. Go into Mac OS then into System Preferences. Look for startup disk. Click on that and select your OS X disk instead of the Vista one.
     
  3. tejota1911 thread starter macrumors 6502

    Joined:
    Nov 10, 2006
    #3
    ethernet76,

    Thank you. That worked perfectly. Now you wouldn't happen to know if it is possible to remove the Vista hard drive icon from my desktop? Also, what about changing the icon and name of the drive. I did this for my MacBook Pro Hard drive, but when i go to "Get Info" on the Vista drive, it won't let change anything. Thank you.
     
  4. ethernet76 macrumors 6502a

    Joined:
    Jul 15, 2003
    #4
    I don't think there is an easy solution to making the disk disappear. I'm sure you could have a terminal script that runs umount, but that's beyond what I know.

    As for the name, try giving it a label in Vista. Windows drives have two names. Their drive letter and a user defined label. When you're in Vista right click and go to properties. Look for drive label and change that.
     
  5. sycho macrumors 6502a

    sycho

    Joined:
    Oct 7, 2006
    #5
    Go into disk utility and click on the windows partition, and then click "unmount"
     
  6. M@lew macrumors 68000

    M@lew

    Joined:
    Nov 18, 2006
    Location:
    Melbourne, Australia
    #7
    Just go to finder preferences and hide all HD icons.
     

Share This Page