Macbook Pro back from repair - won't boot with old HD

Discussion in 'MacBook Pro' started by Beliblis, Sep 4, 2014.

  1. Beliblis macrumors regular

    Joined:
    Dec 31, 2011
    #1
    Hi all,

    Bit of a 'complicated' story: My 2011 MBP had a GPU failure, so I gave it to an independent repair centre and had the GPU replaced. In the meantime I was working from an old MacMini (unibody) which I had borrowed from a friend of mine.

    When working with the MacMini, I simply plugged my old internal SDD (with Mavericks installed) from the MBP into a USB enclosure and connected it to the MacMini. That way, I was able to work within my system environment with all my Apps / Mail / Calendar setups etc...
    I was surprised to see that this worked without problems. (I was expecting the Mac Mini may not be happy with having a MBP Mavericks system, but no problems at all!)

    Today the MBP came back from repair and it seems all good. (The repair centre said they always run 8h tests prior to returning the laptop).
    So I removed the SSD from the MacMini and put it back into the laptop.... The problem Im having now is: The MBP can boot in recovery mode – but it won't boot from the actual Mavericks system on the SSD.

    As soon as I turn the MBP on, it chimes, shows the Apple logo, then the Apple logo disappears and the machine keeps booting for minute after minute with the fans spinning.
    Like I said: Recovery mode is fine.

    When I reconnect the SSD to the MacMini, it boots up normal....

    I'm baffled.... Am I missing something?? Any ideas??

    Thanks a lot everyone!!
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Does the drive that was in the MBP when you sent the laptop in for service boot up into OS X?

    ----------

    Boot up using verbose mode (cmd-v) and see what it says.
     
  3. Beliblis thread starter macrumors regular

    Joined:
    Dec 31, 2011
    #3
    Thanks very much for this valuable hint! It worked a treat.
    How is this possible, i mean: what is happening in Verbose mode?

    Quite like that verbose mode. Can I boot in verbose all the time in the future?
     

Share This Page