macbook pro backslash not working

Discussion in 'Mac Basics and Help' started by jim4545, Jun 29, 2008.

  1. jim4545 macrumors newbie

    Joined:
    Jun 29, 2008
    #1
    Hi, I'm having trouble with my backslash "\" button. It doesn't work! I click on it and it doesn't do anything but pipe does "|".
    Can anyone help me work out why it doesn't work and how I can get it to work? I need the backslash for programming.
     
  2. ergdegdeg Moderator emeritus

    ergdegdeg

    Joined:
    Oct 13, 2007
    #2
    What keys exactly are you pressing? And what language keyboard do you have?
     
  3. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #3
    could you possibly have changed the country settings?? this could change the keyboards layout and such.

    try this:
    1. system preferences
    2. international
    3. input menu (tab)

    make sure everything looks normal, i have the "character palette" (the first option in my list) selected and my country's name selected. that should be all thats needed.
     
  4. jim4545 thread starter macrumors newbie

    Joined:
    Jun 29, 2008
    #4
    The key I'm pressing is the one above the shift tab on the right left to the return button. The keyboard layout is English, United Kingdom. And I can't see anything in the international that would make it better.
     
  5. markman641 macrumors newbie

    Joined:
    Apr 21, 2009
    #5
    Problem Found

    :apple::apple::apple:I had just had the same problem.
    But I finally found it out.:D

    I was fumbling around trying to find the problem, so i went to my desktop, clicked something, and pressed "\" key by accident. Then I heard the bot speaking. So I'm like, "What?" And I do it again, and hear it again. So thats when i think "Ohhh! Let me go to my speech preference and see if i can fix it!" So I went there, and saw that somehow "\" got set to "Speak selected item"

    Here is how you fix it if it speaks a item like me:

    1) Go to System Preferences
    2) Click "Speech"
    3) Click "Text to Speech"
    4) Find the thing that says "Speak Selected Text When Key Is Pressed"
    5) Either:
    1. Uncheck the box
    2. Click "Set key" and change it.

    ________________________________________________________________

    :apple::apple::apple:The Mac Man, The Markman! :apple::apple::apple:
     
  6. windstarfy macrumors member

    windstarfy

    Joined:
    Dec 16, 2008
    #6
    Could be your keyboard settings. Try setting the keyboard layout to US. There are two types of keyboards, US layout and the general layout.
     
  7. jim4545 thread starter macrumors newbie

    Joined:
    Jun 29, 2008
    #7
    markman641 - that was indeed the problem! and I did work it out a few months back, but forgot to update this forum page.
    Thanks anyway
     

Share This Page