Macbook Pro Boot Camp Crashes

Discussion in 'Mac Basics and Help' started by marcopolo9, Oct 3, 2008.

  1. marcopolo9 macrumors newbie

    Joined:
    Aug 24, 2007
    #1
    Hello,

    I just installed boot camp with windows xp sp 3 on my macook pro to play Warhammer. Everything seems to run great, but when I start Warhammer Online right after the intro movie (when the game is actually "loading") everything goes to black, the music keeps playing, and windows is frozen (nothing responds). Otherwise xp runs great, but the only thing I want it for is WAR.

    My laptop is a 2.16 C2D, 2 gigs, x1600. All of my drivers should be updated (ati's site and selected the most recent for boot camp/mbp/xp). Also, windows is updated (SP3 etc) as well as boot camp (2.1).

    Any suggestions to fix this problem? Are there known issues with boot camp and gaming?

    Thanks.
     
  2. Delameko macrumors member

    Joined:
    May 1, 2008
    #2
    You should try another game if you have one, or even a demo.

    If it works then I'd say it's not a problem with your Mac/Bootcamp but more with WAR, and you should check over on their support forums to see if anyone is suffering from the same issues.
     
  3. marcopolo9 thread starter macrumors newbie

    Joined:
    Aug 24, 2007
    #3
    MBP x1600 boot camp issues

    Good idea. I downloaded the Spore Creature Creator Demo (it supports x1600, 2.16 c2d, etc). After the install the game runs to show the production names (EA etc) and I get a cursor. Then the screen goes black as the music begins to play. Nothing ever comes up on screen, and the music continues to play, but I can still move my cursor and ctrl+alt+dlt to get out of the game (so it's not a hard freeze like WAR had). The task manager says the game is not responding.

    After I'm out of the game, I can see that ATI VPU Recover Error Report Send box. So my problem must be with my gfx card/drivers. I have the latest version from ATI's site (I think) 8.430. How do I check if my directx is up to date? Is that separate from the drivers?

    I ask because when I click to launch spore again (after the error if I don't restart), I get an Alert that says "Could not create the Graphics Device. Direct X is unavailable." Actaully, all things graphics related are a little laggy/weird after that first crash (until I restart).
     
  4. marcopolo9 thread starter macrumors newbie

    Joined:
    Aug 24, 2007
    #4
    Has anyone had an issue with no games working in xp with boot camp 2.1 and sp3? It has to be the video card, but I dunno where to start with that.
     
  5. Delameko macrumors member

    Joined:
    May 1, 2008
    #5
    If you go to the Start menu and click Run...
    Then type 'DxDiag' that should bring up the Direct-X diagnostic program and show you everything you need to know, including version and if anything is not working correctly.

    The latest version for XP should be 9.0c (I don't think DirectX 10 works on XP anyway).
     
  6. vgsmobsterns macrumors newbie

    Joined:
    Oct 29, 2008
    #6
    I too have had this issue. Im using one of the new macbook pros. I have been playing fallout 3 and lord of the rings battle for middle earth. The issue has happened with both the games. Any fixes for it?
     

Share This Page