Macbook Pro Boot Problems

Discussion in 'Mac Basics and Help' started by nvanprooyen, May 5, 2016.

  1. nvanprooyen, May 5, 2016
    Last edited: May 5, 2016

    nvanprooyen macrumors newbie

    Joined:
    Jul 16, 2014
    #1
    Ugh. I've been messing with this the better part of the morning. On boot, I get a black screen. Pressing the caps lock key, the light toggles on and off and I also hear the startup sound on boot...so think it's a display issue. This started yesterday when all the sudden the screen went black in the middle of using it.

    So far I've tried:

    - Resetting the SMC, multiple times
    - Resetting the NVRAM, multiple times
    - Booting into safe mode. I got this to work once, but it took a REALLY long time. They keyboard wasn't lit up, so I didn't think it was doing anything...then all the sudden the login screen popped up after maybe 10-15 minutes.

    Really hoping I can get this figured out. Losing it for several days to Apple Support would kill productivity. Any ideas?

    Edit> MB Pro Retina 15", i7, El Capitan. 2012ish I think.
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #3
    Yep, as JohnDS said, it could well be the GPU on its way out -- going on the assumption that you have the 2012 rMBP. Best to take it to an Apple Store. If that is the problem, they'll repair it free of charge, even if you're out of warranty.
     
  3. nvanprooyen thread starter macrumors newbie

    Joined:
    Jul 16, 2014
    #4
    I got it to boot again into safe mode and was able to verify that it's a Mid 2012 rMBP, so it looks like it's covered under this. Guess it's time to back up and bring it in. Thanks all!
     
  4. nvanprooyen thread starter macrumors newbie

    Joined:
    Jul 16, 2014
    #6
    Thanks JohnDS. Looks like it's covered. Now I gotta get my dusty iMac all setup so I have something to work on while they fix this thing :) Any idea on what their typical repair turnaround is? Couple weeks?
     
  5. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #7
    I think they will tell you 3-5 days. I got mine back in 3 days with mail in.
     

Share This Page