Macbook Pro Booting Issue

Discussion in 'MacBook Pro' started by simultech, Jan 4, 2008.

  1. simultech macrumors newbie

    Joined:
    Apr 8, 2007
    #1
    Hi all,

    I have an annoying problem with my Macbook Pro, and can't seem to find others with the problem (I have looked and googled, its happened for a while).

    Problem:
    When I restart my macbook pro (C2D 2.33 15"), the computer won't boot, the sleep light just sits there. If I force shut down (holding down apple+alt+power), and then turn it back on, it still won't boot. To get it up and running again, I have to leave it off for an hour, and it boots back on fine. It first happened when I was in SanFran for WWDC, installing the leopard WWDC beta (as ironic as that is).

    What Ive tested:
    * Replaced the battery
    * Done all the apple shortcuts (clear the PRAM etc. etc.) a few times
    * Removed the battery and tried powering while plugged in
    * Installed the latest bios updates (which was scary cause it needed to reboot to flash the bios, and of course the problem struck, but luckily I left it for an hour, then turned it on, and it flashed)
    * Formatted multiple times
    * At first I thought it was when CD's were in the drive, but it happens regardless

    Has anyone seen or had this problem before? It is driving me nuts, especially when updates come out that require a reboot.

    I do have applecare, but unfortunately a family member spilt some water on the computer about 6 months before it started happening, so I am scared to take it in and loose applecare (while it makes applecare seem useless, I can still use it if I have problems with batteries or power adapters).

    Any help would be GREAAAAATLY appreciated.
     
  2. pianodude123 macrumors 6502a

    pianodude123

    Joined:
    Mar 1, 2005
    Location:
    in the internet
    #2
    I am having this same problem, however my computer starts up about 1/10 times you ask it to. It also just randomly powers off when it is running. This problem started out ok, but it seems to be getting worse. I cant even seem to power the computer on now...
     
  3. e12a macrumors 68000

    e12a

    Joined:
    Oct 28, 2006
    #3
    Do you mean when you press the power button to turn the computer on, nothing happens? No tone, no fan noise, HD noise...just a solid sleep light?

    I've had that happen, but I've never force shut it down while it was doing that. I waited it out (only like 20 seconds) and it boot up normal. Try just waiting for it.

    edit: oh and the corroding from the water might just be taking effect.
     
  4. pianodude123 macrumors 6502a

    pianodude123

    Joined:
    Mar 1, 2005
    Location:
    in the internet
    #4
    mine has never been exposed to water, it has just been dropped, once. It worked fine for a while after that, but a month ago, it started doing this... right when i was out of applecare. When i turn it on, the hard drive spins, but the keyboard does not work... when i hit caps lock, no light turns on... i've waited up to an hour for it to boot. the screen does not turn on either. the hard drive makes no noise as if it is accessing information... it just spinds.
     
  5. pianodude123 macrumors 6502a

    pianodude123

    Joined:
    Mar 1, 2005
    Location:
    in the internet
    #5
    i have my computer wide open now with all of the parts taken out... what should i look for to see if anything is loose?
     
  6. simultech thread starter macrumors newbie

    Joined:
    Apr 8, 2007
    #6
    So I also pulled apart my MBP last night :p

    Had a look and thankfully there is no water damage, looked like it all stayed out (even below the holes for speaker areas).

    When I put it together, I still had the same booting problems. I finally got it to boot, and left a reinstall of Leopard going overnight. When I woke up, it was in Leopard, which means it had rebooted once or twice (which means it didn't crash on boot). What I am thinking is that it had potentially 6 hours to try and boot, which if it did, it may have cleared up whatever the problem was (ie: EFI caching?) and I am going to try restarting now. If it works, there is a potential solution, if not, well square 1.
     
  7. jamesybsu macrumors regular

    Joined:
    Jun 12, 2007
    #7
    i dropped my Powerbook and about 3 months after I dropped it I had the problem that sleep light would be on all the time, even when I was using my computer, and then it slowly stopped turning on, like just start spinning and nothing but the apple screen at start. I was told by an apple repair technician that my logic board was failing because I dropped it, which sucked cause it would have cost like 750 bucks to replace it and get it installed. So I sold it as is and bought a MBP instead :)
     
  8. simultech thread starter macrumors newbie

    Joined:
    Apr 8, 2007
    #8
    Nope, no luck

    Started install
    Woke up this morning (Rebooted fine)
    In OS-X
    Installed 10.5.1, quicktime and itunes
    (Rebooted fine)
    Installed MBP1.1 update
    (Sitting here, black screen, sleep light on)

    Now I know already from experience, if I force shut-down, leave it off for an hour, and turn it back on, it will be fine.

    But yes, any ideas WHY
     
  9. stafh macrumors newbie

    Joined:
    Jan 16, 2008
    #9
    I have the same problem, except my macbook pro takes about 2 hours & 23 minutes before it boots. I have never exposed it to water or dropped it or anything like that. It just froze up one day and when I rebooted it the problem appeared.
    I also tried resetting everything, but nothing works. :(
     

Share This Page