MacBook Pro Boots Up, but No Video

Discussion in 'Mac Basics and Help' started by Geoff Myers, Dec 22, 2008.

  1. Geoff Myers macrumors member

    Joined:
    Mar 19, 2007
    #1
    When MacBook Pro is turned on, the startup chime sounds and there is hard drive activity, but screen remains blank. No video appears on the monitor, even if I trigger F7, +F2, or turn up the brightness. Not a backlight issue because not even a very faint picture appears. I know the screen itself works because this issue happens intermittently (it fixes itself sometimes, and the screen works perfectly). I tried zapping the PRAM and resetting the PMU.
     
  2. Schtumple macrumors 601

    Schtumple

    Joined:
    Jun 13, 2007
    Location:
    benkadams.com
    #2
    Sounds like your GPU might be gone, take it to an apple store, they should replace the logic board for you free of charge, providing you haven't done any accidental damage to the case, or split liquids onto it (they'll be able to tell).
     
  3. rtmadden macrumors regular

    Joined:
    Jun 18, 2008
    Location:
    Maryland
    #3
    Any chance of connecting to an external display?
     
  4. Geoff Myers thread starter macrumors member

    Joined:
    Mar 19, 2007
    #4
    Yes, I connected it to an external LCD monitor but nothing shows up on the screen when I boot up the computer... I tried hitting F7 to switch display modes, but that didn't help.
     
  5. amoda macrumors 6502a

    Joined:
    Aug 9, 2006
    #5
    The graphic card died, they'll have to do a logic board replacement.
     

Share This Page