MacBook Pro C2D wireless random disconnects.

Discussion in 'MacBook Pro' started by macsat, Jul 1, 2007.

  1. macsat macrumors newbie

    Joined:
    Dec 7, 2006
    #1
    Hi

    I have a MacBook Pro C2D which has started to do random disconnects from my WLAN.

    I am running the lastest Tiger 10.4.10

    No matter if I use the network connection actively by surfing, chatting, listening to netradio, downloading or if it is just idle, it randomly disconnects. Sometimes after 30 mins, sometimes after several hours.

    It never reconnects itselves until I do it manually. But then it has no problem reconnecting.

    It is quite annoying, especially since I sometimes run services like a web server (for development reasons) and sometimes want to download large files using either http, ftp or bittorrent. But I cannot trust it to finish the downloads, as it randomly disconnects.

    It havent always done theese things. It has started occuring after the last couple of updates from Apple I think (dont remember excately when).

    I have read some tips and tricks on the web, but is yet to find one that works. I have (amongst other things) put my wireless connection at the top of the list of network connections.

    Nothing seems to work.

    I have 3 different accesspoints with different wireless chipsets, but it occurs on all of them. Also I have a couple of PC Laptops that dosnt have this problem on my network.

    Have somebody seen similar issues, and more importantly - found a way to fix it?

    regards
    K


    PS. Just to stress my point, it just disconnected as I pressed "Submit New Thread" :-(
     
  2. Smoothie macrumors 6502

    Joined:
    Jun 23, 2007
    Location:
    California
    #2
    Is your signal strength fluctuating? If the strength drops enough for a long enough period of time, it will probably lose the connection. I'm about 25 feet from my router, and the signal strength will fluctuate. It could be the result of interference. Occasionally, but not at all frequently, I'll lose the connection and have to manually reconnect.
     
  3. macsat thread starter macrumors newbie

    Joined:
    Dec 7, 2006
    #3
    It is sometimes fluctuating a bit, but not much (maybe it looses one bar sometimes). I did consider interference myselves, but I have searched with NetStumpler (windows) and iStumpler and found that all other networks I see are on channels 6 - 11 - hence I put mine on channel 1. Still get the dropouts.
     
  4. emex macrumors newbie

    Joined:
    Nov 21, 2006
    #4
    I have the same issue with mine.

    It used to work perfectly with no dropouts when I was using my old cheapo bottom-rung Netgear but now with my new top o' the line Netgear with the draft N protocol I'm getting dropouts around 30 minutes in or no connection when I open the lid until I manually re-add the connection. Sometimes turn airport on and off works too.

    Weird stuff.
     
  5. mantic macrumors 6502a

    Joined:
    Mar 30, 2007
    Location:
    AL
    #5
    Mine did the same with that router .. I returned it and went back to my old g router.
     
  6. macsat thread starter macrumors newbie

    Joined:
    Dec 7, 2006
    #6
    Mine is a G router......All 3 of mine are :)

    I've tried with an ASUS WL-500G Premium, a SMC SMCWAPS-G and a Zyxel P660HW.

    All with same unstable result (and all G models).
     
  7. jettoblack macrumors member

    Joined:
    Nov 1, 2006
    #7
    Many people are reporting the same thing after the 10.4.10 update. I was having terrible disconnect issues until I reinstalled 10.4.9, now my wi-fi is perfect.
     
  8. macsat thread starter macrumors newbie

    Joined:
    Dec 7, 2006
    #8
    I'm afraid that I'm a bit of a OS X newbie. Is it possible to roll back, so that I dont get the 10.4.10 update ?
     
  9. magius macrumors regular

    Joined:
    Jun 3, 2007
    #9
    i was having the same problems until i changed the settings on my router. i'm not sure exactly what i changed, but i do know i changed the encryption from wep to wpa and switched it to channel 7. since then i have had no disconnects. you can test whether its a router problem by either going to a different connection area, or turning off all security on the router for awhile to test if it still screws it up.
     
  10. macsat thread starter macrumors newbie

    Joined:
    Dec 7, 2006
    #10
    I pinned my issue to one specific setting in my wireless router.

    In WPA mode, this setting affects the stability of my link:
    ReAuthentication Timer

    It is normally set to 1800 secs (30 mins) - and this makes my MBP disconnect every - yes - 30 mins...almost. Sometimes it tend to survive the interval.

    The valid range is 10-9999 seconds in my router.

    If set to 10 secs, it almost disconnects all the time - every 10 secs.

    If set to 9999 I can work some hours without disconnects (my guess is 9999 secs, or 166 mins).

    It seems like some update from Apple in the 10.4.10 release, effeciently broke the WPA encryption implementation of ReAuthentication.

    It makes no difference to switch between WPA and WPA2.

    No encryption is rock stable - but I really do need WPA - as there are a lot of people around here, and I'd like to stay somewhat safe. (I can see som 10+ WLANS in my appartment).
     
  11. sfisher macrumors regular

    Joined:
    Jun 20, 2007
    Location:
    Albuquerque, NM USA
    #11
    That's a good catch. I recommend reporting it directly to Apple so they can fix it :)
     
  12. macsat thread starter macrumors newbie

    Joined:
    Dec 7, 2006
    #12
    .......And how do I do that? :)
     
  13. chem macrumors regular

    Joined:
    Jun 9, 2007
    #13
    I dunno, call Apple's support lines instead of posting to some random rumors website? :)
     
  14. robotica macrumors 6502a

    robotica

    Joined:
    Jul 10, 2007
    Location:
    Edinburgh
  15. sree.nilakanta macrumors newbie

    Joined:
    Oct 19, 2008
    #15
    And the story goes on...

    I have Powerbook with Leopard. It contnues to disconnect from my Linksys router every few minutes. For days it will have no problem but then some days it goes on a rampage! I have scoured every forum and read every suggestion except one from Apple (Apple does not have a suggestion that works). With this behavior there is no difference between XP and OS X. I was thinking of buying a new Macbook or Powerbook but based on this experience I will not buy one. Instead I will buy a netbook from HP or Dell.
     
  16. frenetic macrumors regular

    Joined:
    Feb 11, 2004
    Location:
    Amsterdam
    #16
    So here we are two years later and still no fix :)

    To be fair, it is not Apple's fault. The internetz are full of people reporting problems with these Zyxel modem. Apparently their implementation of WPA is not compatible with a certain number of chipsets, including Apple's. The only solution is putting security on WEP and then it won't happen again. It is true that WEP is very insecure, but where I am there is no download limit soI won't mind the occasional people making use of my network.

    Cheers
     
  17. Antexter macrumors newbie

    Joined:
    Apr 17, 2010
    #17
    Solved

    I've been struggling with this issue since i got my new draft N router, but have finally found my solution.

    I found the problem by changing the re-keying to around 300 seconds so i could test it and yep it kept kicking me off.

    So i knew it was something to do with that, so kept changing things and finally found the issue was AES encryption, when I changed this to TKIP it was working perfectly fine :D.
     
  18. Chupa Chupa macrumors G5

    Chupa Chupa

    Joined:
    Jul 16, 2002
    #18
    I had the same issue with my MBPs. It was maddening as it would reset every few hours. The cultprit seemed to be interference as my main base station was right next to my refrigerator. Once I moved it away the problem pretty much went away. I still get random resets but they are weeks apart now which I can deal with.
     

Share This Page