MacBook Pro can no longer connect to router after accidentally unplugging it.

Discussion in 'Mac Basics and Help' started by Glumpfner, Feb 5, 2011.

  1. Glumpfner macrumors regular

    Joined:
    Dec 15, 2009
    #1
    Hi there,

    I was working on my MacBook Pro (13 inch latest model) and I was surfing the net while being connected via WiFi to my router. Then my girlfriend plugged out the power socket of the router by accident. After she plugged it back in the Router started again, but the SSID no longer showed up on my MacBook.

    On my iPhone it works without a problem. Also on my flat mates PCs they have the NEtwork back and can connect without a problem.

    Funny thing is all the Networks from my neighbours show up. I live in a high rise building in Vancouver, Canada and I get about 30 signals from different networks, except my own router doesnt show up!

    I restarted my MacBook Pro several times over the past 24 hours. Left my laptop off. Turned it back on. Turn Airport on/off dozens of times.
    I also selected "Join other Network" and then entered the SSID manually and the password and selected the proper security as well (WPA2 Personal) but all I get is a "time out".
    I also deleted all the saved networks in the preferences.

    I also unplugged the router again and left it off for over a minute. Turned it back on, after a minute my iPhone finds the signal and connects within seconds, same for my flat mates PCs. But my MacBook just doesn't won't even show the SSID of my router.

    What can I do?

    Is there some sort of Cache I could delete?

    EDIT
    Not sure if this helps, but when I connect to the router using a cable it works straight away, so it just seems that my Mac can't get the signal of the router anymore.
     
  2. dmmcintyre3 macrumors 68020

    Joined:
    Mar 4, 2007
  3. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #3
    In all likelihood what you're experiencing is interference. You should probably try changing the channel of your router to one less commonly used. If you are running Mac OS X 10.6, you can see in System Profiler under Network->AirPort information about "Other Local Wireless Networks." Look at the channels in use, and while connected to your router via Ethernet, change the channel to one not in use by the other visible networks. Note: even though your iPhone and housemate's PC are not affected, take into account that the radio antennas are different configurations.
     

Share This Page