MacBook Pro can't connect to the printer

Discussion in 'Mac Basics and Help' started by Constancex, Aug 15, 2013.

  1. Constancex, Aug 15, 2013
    Last edited: Aug 15, 2013

    Constancex macrumors newbie

    Joined:
    Aug 5, 2013
    #1
    I just bought an epson xp-410, a wireless printer. It prints when I connect the laptop to it with the USB cable. If its not connected to the USB cable, it says offline. I have OS X mountain lion

    How can I connect it to the laptop? I went to print and scan, then clicked the "+", to add the IP address. Yet it still doesn't work
     
  2. Thraun macrumors regular

    Thraun

    Joined:
    Dec 18, 2008
    Location:
    Abbotsford, BC
    #2
    Have you entered your network information on the printer itself? Obviously the computer won't see it on the network if it's not connected.

    Also, this was a few years ago now, but when I got my Epson printer it wouldn't connect wirelessly until I went to the Epson website and downloaded the specific driver for that model printer and my operating system (10.6 at the time).
     
  3. Constancex thread starter macrumors newbie

    Joined:
    Aug 5, 2013
    #3

    I set up the wifi on the printer and entered the pw. I downloaded the specific driver on the website and updated it. I typed in the IP address into laptop and there was no luck
     
  4. END3R macrumors member

    END3R

    Joined:
    Jan 27, 2009
    #4
    My Canon is found in the Default tab when adding a new printer in "Print & Scan" system settings. Could it be possible that it's not set up correctly? Also, it is a scanner as well but I can only scan if it is connected through USB and the "Location" is listed as "My Macbook Pro" and not shown as an AirPrint device. Not much help but maybe try going through setup again.

    Off the topic, some Epson printers don't allow you to refill the ink cartridges. Just mentioning.
     
  5. firedept macrumors 603

    firedept

    Joined:
    Jul 8, 2011
    Location:
    Somewhere!
    #5
    I would suggest reinstalling it. I have seen this before with a friends Brother printer. After reinstalling it, the problem cleared up. Not sure it will help, but is a suggestion.
     
  6. Constancex thread starter macrumors newbie

    Joined:
    Aug 5, 2013
    #6
    Tried reinstalling it and didn't work either. First I connected the printer to the USB drive and it works. The printer name is in there but it says offline when not connected to the cable
     
  7. Knoodles macrumors 6502

    Knoodles

    Joined:
    Feb 2, 2003
    Location:
    Gone to the Beach
    #7
    Don't know if it's the same, but with my Canon all in one you have to set up the wireless while connected via usb using the setup software on the included disc.
     

Share This Page