Macbook pro can't turn on with 667mhz ram

Discussion in 'MacBook Pro' started by peterpanx, Apr 7, 2014.

  1. peterpanx macrumors newbie

    Joined:
    Apr 7, 2014
    #1
    Hi. I would like to share with you my macbook's recent strange behaviour asking for your help.
    I have Installed 4GB ram on my Macbook pro 4.1 includes 1 memory card ddr 667mhz and the second as ddr2 800 mhz.
    Recently I successfully repaired my laptop with reballing -not the trick with the oven,it repaired with the official way- .The laptop used to work with a pair of dd2 667 mhz ram but we lost the second piece of 667 module and finally, ended up with the previous memory set-up (667,800 mhz).
    Today,I tried to boot up my laptop and the machine denied it.When I press on, it works for 3 seconds and then it switches off.When I remove the 667 Mhz (notice, this kind of module is the default for this model) and try to start ,It works without closing in the third sec but it doesn't boot up at all,because it freezes in a black window without the start up chime,that means that there is obviously a hardware problem.I tried several ram combinations including one pair of 1 gb 667 mhz ram (with whis gear i bought my computer as a new) with actually no luck.
    Therefore,my question is why the computer doesn't turn on with the default type of ram and it works only with the 800 mhz one that is not.It's a very strange behaviour.
    About the principal issue,I'm able to give it back to service while I'm on the 3 months guaranty.
    Thanks in advance for your help.
    P.
     
  2. Steve121178 macrumors 68040

    Steve121178

    Joined:
    Apr 13, 2010
    Location:
    Bedfordshire, UK
    #2
    The DDR & DDR2 combo won't work.
     
  3. peterpanx thread starter macrumors newbie

    Joined:
    Apr 7, 2014
    #3
    You are right.It was a typing mistake,however the combo was dd2 667Mhz and ddr2 800Mhz.
     

Share This Page