Macbook Pro connected to Wifi but not the internet

Discussion in 'MacBook Pro' started by Chrisjph, Mar 18, 2014.

  1. Chrisjph macrumors newbie

    Joined:
    Mar 18, 2014
    #1
    Hi.

    Basically, my macbook pro has full wifi signal and the other computers in the house work, but mine won't load internet pages.

    I've tried resetting the router, restarting the computer and updating software, moving that folder to the trash and then restarting the computer.

    However, no luck…

    Does anyone have any idea of how this can be fixed or shall I just wait and see if it fixes itself?

    It happened yesterday evening suddenly and I don't know why?
     
  2. stu.h macrumors 65816

    stu.h

    Joined:
    May 8, 2010
    Location:
    West Midlands, England.
    #2
    Check for static DNS in there.
    Try completely deleting the wireless configuration to your router and reassociating it with it.
    Try with a physical cable to rule out browser issues, or download another browser (chrome, Firefox) and see if the problems persist.
    Can you open 'Terminal' in Launchpad/Other Utils and type
    Ping www.macrumors.com
    Do you get a reply?

    Then report back...

    :)
     
  3. Gav Mack macrumors 68020

    Gav Mack

    Joined:
    Jun 15, 2008
    Location:
    Sagittarius A*
  4. Chrisjph thread starter macrumors newbie

    Joined:
    Mar 18, 2014
    #4
    I've deleted the wireless configuration but it doesn't delete the password so it automatically connects. Is there a way to delete it and the password so I need to input the password again?

    I can open 'Terminal' and type in it. I have also tried other browsers.

    Have you got any idea?

    Thank you :)
     
  5. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #5
    Try booting in safe mode. Hold left shift key on startup. Also try a new or different user account.
     
  6. Chrisjph thread starter macrumors newbie

    Joined:
    Mar 18, 2014
    #6
    I have now tried using the ether cable and the internet works that way, so does anyone know why the internet won't work through the wifi.

    I've also tried being next to the router connecting through the wifi but still no luck.

    I have shut down the computer and restarted it up.

    And I also found the way of reconfiguring a connection with the wifi which was delete the network then shut down and start up, but no luck either.

    Tried safe mode and creating a new user account and that didn't work either.

    Any more suggestions?
     
  7. Chrisjph thread starter macrumors newbie

    Joined:
    Mar 18, 2014
    #7
    Don't worry. It's been fixed now...I think it was something to do with the IP address.
     

Share This Page