MacBook Pro disconnects from wi-fi

Mildredop

macrumors 68020
Original poster
Oct 14, 2013
2,410
1,458
This is a problem I've had for months but only now have got round to finding out the issue.

My MacBook Pro seems to have trouble connecting to wi-fi networks. When it wakes from sleep it takes about 30 secs or so to find and connect (the wifi symbol in the toolbar does that up-and-down animation).

Even if I leave my Mac on and open, once the screen goes to sleep when I come back to use the Mac, it has disconnected from the wifi and I have to wait another 30 secs whilst it reconnects. This also means emails etc. don't come through.

What is the problem?

If it's helpful I have a TP-Link Archer VR600 router.
 
Last edited:

smallcoffee

macrumors 68000
Oct 15, 2014
1,575
1,963
North America
This is a problem I've had for months but only now have got round to finding out the issue.

My MacBook Pro seems to have trouble connecting to wi-fi networks. When it wakes from sleep it takes about 30 secs or so to find and connect (the wifi symbol in the toolbar does that up-and-down animation).

Even if I leave my Mac on and open, once the screen goes to sleep when I come back to use the Mac, it has disconnected from the wifi and I have to wait another 30 secs whilst it reconnects. This also means emails etc. don't come through.

What is the problem?

If it's helpful I have a TP-Link Archer VR600 router.
You may have an option selected somewhere for the Mac to not update or to disconnect from wifi when it sleeps.

It seems from your description the issue only happens while sleeping or waking from slee.
 

Open Casket

macrumors member
May 3, 2017
46
8
I used to have a similar problem when I had a tonne of previous networks stored in my computer.

I'd start by going into System Preferences, then Network. On the side is a list of networks that your computer has been connected to. If you're never going to use a network again (like if you'd previously tethered your phone), delete it.

Also in System Preferences, there is an option called Power Saver. Try ticking the Enable Power Nap box.

Although, I am assuming that you're connecting to your home WIFI here. If you're at a cafe or a food court, those bad-boys usually have a timer for guests so they will kick you off after about 30 minutes.