macbook pro disrupts wireless connection for all other laptops on the network

Discussion in 'MacBook Pro' started by macinspain, Sep 4, 2011.

  1. macinspain macrumors newbie

    Joined:
    Sep 4, 2011
    #1
    My macbook pro will not connect to the internet through the web browsers. Airport says that everything is connected properly, full strength, but the browser says there is no internet connection. The router is working fine for 3 other computers, 2 PCs and one macbook, but as soon as I try to connect with the mbook pro, it disrupts the whole network, and the IP warning, one IP address being shared, pops up. However, all the computers show full strength connection, but the browsers won't connect. Interestingly enough, Skype works on both macs, but the browser is disrupted.

    I've tried several fixes, power cycling, changing the IP address, using proxies, running network diagnostics, nothing has produced any results. Once the macbook pro is closed, and the router is restarted, all the other computers can once again browse, but as soon as I try to connect with the pro, everything shuts down again. I've looked through several threads, such as this one, which I tried, (https://discussions.apple.com/thread/3082192?start=0&tstart=0), but it didn't work. I've looked through several other threads and tried several different solutions, but nothing is working. If anybody has any ideas about fixing this, please let me know, I would really appreciate it. Thanks
     
  2. macinspain thread starter macrumors newbie

    Joined:
    Sep 4, 2011
    #2
    thanks so much for the overwhelming display of support
     
  3. cfII macrumors regular

    Joined:
    Jul 31, 2011
    Location:
    california
  4. sdb53 macrumors newbie

    Joined:
    Apr 17, 2011
    #4
    Mine does this to sometimes and MacBook Pros don't disrupt the connection because at my school they give either an HP or Macbook Pro to every student and 70% of the people have MacBook Pros and there is no problem. But when my browser does that I just turn the airport off for 2 minutes and then turn it on and it usually works.
     
  5. cfII macrumors regular

    Joined:
    Jul 31, 2011
    Location:
    california
    #5
    we should NOT have to do this, my mom is taking her MB in to genius but i think its a network problem...any ideas?
     
  6. phyrexia macrumors 6502a

    Joined:
    Sep 3, 2010
    #6
    Is your network set up to assign IPs with DHCP? Is your laptop also set up to use DHCP?

    If you manually assign IP addresses to all of the machines in your network, does the problem go away?

    Try to manually assign an IP to your MBP that is outside the range of IPs that your router will give via DHCP. That should keep any IP conflict your MBP is causing from occurring.

    Maybe performing a hard reset on your router would work.
     
  7. dusk007 macrumors 68040

    dusk007

    Joined:
    Dec 5, 2009
    #7
    What do you mean by, you've tried chaning the IP address?
    Simply in the Network settings, which wouldn't do you any good but who knows if you know what you are doing.
    Did you try what phyrexia said, or did you turn of DHCP altogether and did it completely manual?

    If your router does such nonsense I would try a firmware upgrade. If that is not an option the only thing you can try is forcing IP address on the machines in a semi manual or completely manual way.
     
  8. crimton macrumors member

    Joined:
    Sep 20, 2011
    #8
    I too was having problems with connecting to web pages on my new MBP. All the other computers and devices on the network would connect fine but my macbook would just try to load pages but never would. I tethered from my phone and it would connect fine. I booted into windows and it would connect fine. My router was a netgear gateway router/modem from my ISP that I have been renting. So I figured I would just buy a modem and router and see if that fixed the issue while also saving myself some money on my bill. I got a medialink wireless n router from amazon and since I hooked it up I have not had 1 problem. My MBP loads up pages super fast and never loses its connection anymore.
     
  9. cfII macrumors regular

    Joined:
    Jul 31, 2011
    Location:
    california
    #9
    thread being suprresed

    seems like no one wants to talk about this, like maybe we should keep it on the DL, are we all using LION? I am and im betting others w the problem are too
     
  10. crimton macrumors member

    Joined:
    Sep 20, 2011
    #10
    I'm on Lion too, and as I said the problem has been solved for me by getting a new router.
     
  11. Shop macrumors member

    Joined:
    Jan 15, 2008
    #11
    My 2009 13" MBP knocks the other computers and laptops off the network when I open it. I've changed routers and tried static IPs.

    I was informed of the problem while running Mountain Lion and I don't know if it was an issue while running Snow Leopard. Mavericks did not fix. Could be hardware or software. Maybe one day I'll wipe and load back to an early backup of whatever this thing came with just to see if it's hardware or not.
     
  12. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #12
    Define "knocked off"?

    Do they lose their ip address?
    Do they lose internet connectivity?
    Does their internet slow right down?
     
  13. Shop macrumors member

    Joined:
    Jan 15, 2008
    #13
    This. They can't access the internet anymore when I wake up the MBP; I have to cycle them through airplane mode or otherwise reset their NICs. No IP addresses appear to change on any machine.

    It's interesting that my iPad is unaffected; only the androids and windows machines have the problem.

    I'm testing the solution in the OP's post (adding a location to the MBP wifi settings instead of using the default "automatic") and so far so good... of course it looked like I had it fixed for a little while when I tried using static IPs. :/

    I need to give it a little more time before I can declare success or failure. The android tablet that usually breaks immediately hasn't failed since this latest test (well, since last night that is).

    Thanks, simonsi!
     
  14. Erphern macrumors 6502

    Joined:
    Mar 6, 2013
    #14
    There's not a lot to talk about - nobody has posted any troubleshooting results.

    What's the gateway IP? Are all hosts DHCP, static, or a mix? Which machines can ping the gateway? What's the default route? Etc.

    If getting a different router has solved the problem for some, it could simply be that a different router has a different gateway address. Who knows. More details required. :)
     
  15. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #15
    It's most likely your choice of routers, they often share firmware (e.g. the UPNP bug). Post the make and model of both, are you running factory firmware?
     
  16. Shop macrumors member

    Joined:
    Jan 15, 2008
    #16
    Showed up while using DLink DIR825 router and stock firmware - flashed to DDWRT, no joy. Switched to an ASUS RT-AC66U (stock only), no joy.

    I'll resume troubleshooting if the fix I'm testing turns out to not be the fix. I'll post an update either way.

    Thanks!
     

Share This Page