Macbook Pro doesn't detect USB flash drive

Discussion in 'MacBook Pro' started by montygraphics, Jan 14, 2009.

  1. montygraphics macrumors newbie

    Joined:
    Jan 14, 2009
    #1
    Hi, I have a Macbook pro (OSX 10.4.11) and all of a sudden it stopped detecting a fairly new Jump/Flash drive that up until now worked fine. The icon doesn't show up on the desktop or in the Macintosh HD window.

    The flash drive has "Dane-Elec" printed on it and is 4GB. I've tried it a number of times and nothing. The drive does still work on other computers, and my usb port is working properly with other devices.

    The flash drive doesn't seem to show up in System Profiler and my Disk Utility has been "gathering information" for about 5 minutes now." Everything else is working fine with the notebook. Any ideas? :confused:
     
  2. MVApple macrumors 6502a

    Joined:
    Jul 18, 2008
    #2
    This may not be very useful, but try a restart. Your situation sounds strange.
     
  3. montygraphics thread starter macrumors newbie

    Joined:
    Jan 14, 2009
    #3
    tried that...

    Yep, I tried rebooting. ok, so I was able to erase the disk using Disk Utility (wouldn't let me repair or anything else), but now when I put it in a message pops up saying "The disk you inserted was not readable by this computer." What's up with that?
     
  4. ildike macrumors newbie

    Joined:
    Jul 22, 2009
    #4
    DaneElec 4GB stickdrive has changed to 400MB

    I have used only ones my DaneElec 4GB stickdrive after I have downloaded the data it has changed to 400MB capcity. On the DaneElec website i find drivers only for Windows. My Imac MacOX 5.4.6 does not recognize it. I wrote to the company email, but they do not reply. I do not use the paralell software....What can I do to reformat my stick? Anybody solved this problem?
     
  5. mainomega macrumors 6502

    Joined:
    Jun 5, 2007
    #5
    did you try it in a different computer ? in all probability the drive is bad not the notebook
     
  6. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #6
    For both: It's probably NTFS formatted so OS X can't read or write it. Format it to HFS+ or FAT32
     
  7. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #7
    If it's formatted as NTFS, it should still be able to read it but not write to it, no?
     
  8. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
    #8
    Try changing the partition scheme when you erase it.
     

Share This Page