Macbook Pro drops wireless internet CONSTANTLY!

Discussion in 'MacBook Pro' started by marchellabella, Feb 26, 2011.

  1. marchellabella macrumors newbie

    Joined:
    Jan 30, 2011
    #1
    Hello,
    My husband is running a 15" macbook pro and I am running a 17" macbook pro. We have AT&T for our internet. Ever since we both got our macbooks a few months ago, our internet drops all the time. At times when we are on at the same time, it is almost every few minutes. Then, in order to get back to what I was doing, I have to clear my history (sometimes 2 or 3 times) in order to get back on. Any page that you were on before, will not work until it clears the history.

    We are both SO stumped, any help would be greatly appreciated! :confused:
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    What kind of router do you have? What kind of modem do you have? Have you tried connecting your computer directly to your router with an ethernet cable to see if the problem persists? How far away from the base station are you when your connection drops? Do any other devices in your house drop the WiFi connection as well? Do your macbooks drop it at the same time?
     
  3. pricej636 macrumors 6502

    Joined:
    Mar 30, 2010
    Location:
    Colorado
    #3
    I had that problem, it was my router. Setting the DHCP lease time higher helped somewhat, but ultimately it was a new router that solved it.
     
  4. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #4
    Do you have Uverse? If so, Google Airport Extreme and Uverse and you'll find a page where an AT&T employee provides some alternative DNS servers that fixed the problem for me.
     
  5. marchellabella thread starter macrumors newbie

    Joined:
    Jan 30, 2011
    #5
    Modem- 2Wire253
    Connecting directly via ethernet cable- have not done this
    We are only about 12-15' away from the modem
    We both have iphones and have never noticed a drop
    Yes the macbooks lose connection at the same time. We will see the router blink red and we both get kicked off.

    (Thanks for your help in advance!)
     
  6. marchellabella thread starter macrumors newbie

    Joined:
    Jan 30, 2011
    #6
    No, we do not have Uverse in our area yet. :) Thanks for trying!
     
  7. skidmarc macrumors member

    Joined:
    Feb 10, 2011
    #7
    Hardwire your laptops to the router and surf the internet like you normally do and see if you get the same problem (it may be uncomfortable and inconvenient). I doubt you'll drop connection.

    If you do, or if you don't, you can always statically assign IP addresses to both both laptops through your router's GUI interface.

    This may, may not help. It will help with troubleshooting though.
     
  8. pricej636 macrumors 6502

    Joined:
    Mar 30, 2010
    Location:
    Colorado
    #8
    From my experience the 2wire modems suck, wireless or not.
     
  9. djasterix macrumors 6502a

    djasterix

    Joined:
    Apr 10, 2010
    Location:
    Paradise City
    #9
    Had the same problem and changed to Open DNS, problem solved...
     

Share This Page