Macbook Pro DVI out not working reliably

Discussion in 'MacBook Pro' started by salilsundresh, Aug 12, 2011.

  1. salilsundresh macrumors 6502

    Joined:
    Dec 11, 2005
    #1
    When I connect an external monitor to my Macbook Pro via the DVI out port using a DVI to VGA adapter and a VGA to VGA cable I am able to get signal. But when I directly connect a DVI to DVI cable I get no signal (no image). Any ideas what could be going on? Also, the VGA isn't super reliable but it works most of the time. Any suggestions would be greatly appreciated.

    Specs:
    15" Macbook Pro, late 2007, 2.2ghz core 2 duo, A1226, OS X 10.5.8,
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #2
    Follow basic troubleshooting practices. Connect known-good cables and a known-good monitor. You'll be able to narrow it down to being either the cables, the monitor, or the computer.

    Anything else based on what you've told us would just be an assumption.
     
  3. salilsundresh thread starter macrumors 6502

    Joined:
    Dec 11, 2005
    #3
    Hi,


    Yes, I tested it on known good cables and monitor. It's certainly the computer...I somehow got dvi to work for a few months and now it's stopped working. VGA doesn't work either. The backlight on my MacBook pro''s LCD panel is burnt out but I've had this problem since before that happened.

    It does make the start up tone and seems to log in as I can hear the sound when you adjust the volume control. I tried resetting the p-ram by holding command+option+p+r while booting up. No luck, supposedly there would be some sort of chimes but all I heard was the start up tone. Just restarts the computer.
     
  4. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #4
    Are you sure it's just the backlight? Shine a flashlight on the LCD. If you see nothing, bring it to Apple immediately. Your machine may not yet be four years old, so you might still be eligible for the logic board replacement.
     
  5. salilsundresh thread starter macrumors 6502

    Joined:
    Dec 11, 2005
    #5
    Well, the dvi out did work for a while with the lcd not working properly. i did shine a light behind the lcd yesterday and saw nothing which is strange because i remember when i did that months ago i saw an image.

    edit: i can't remember if i had the lcd bezel/assembly apart when i was shing a light from the back months ago. would it be possible to see anything by just shining the light with the lcd assembly on (into the apple logo)
     

Share This Page