Macbook Pro Early 2008 take long time to start up

Discussion in 'MacBook Pro' started by DSpiridonov, Nov 2, 2012.

  1. DSpiridonov macrumors newbie

    Joined:
    Aug 25, 2012
    #1
    Hey there,

    I know this question has been posted before, but none of the solutions helped me. I am trying to fix a laptop that takes a few minutes to start up, i would say more than 5minutes. When i start the computer it would show the grey screen with the Apple logo and the little circle would just spin underneath the logo for quiet a while. After it comes off that screen, the screen would become blue for another couple of minutes before it goes to the login screen. I know the laptop is a little old, but even so i don't think it should take that long to start up. Once the laptop has started, it works fine. The other problem is that if it is left without being used for a while, the screen would go black and it won't come back on, unless i forcefully shut it down.

    Macbook Pro early 2008 (4,1)
    Inter Core 2 Duo 2.4ghz
    2GB RAM
    OS Snow Leopard 10.6.8

    So far i have tried a few different solutions and none have helped.

    1. I have tested the hard disk with both the disk utility and apple hardware test utility and the result are that everything is fine.
    2. I have replaced the hard disk with another one, run the same tests and the same results appeared.
    3. I have tried both hard disks on another macbook pro that boots up normally and the laptop boots up normally. So i assume it's not a hard disk issue.
    4. I have reset the PRAM (CMD + Option + P + R), and it didn't solve the problem.
    5. Run both fast and Extended testing via the Apple hardware test tool through the use of the applications DVD disk and result was "No trouble found".
    6. Tried different Mac OS (Leopard) and still the same problem.
    7. If i try to load something from CD with holding C or opening something from a USB stick while holding the Option button, it will load it just as slow as from the actual hard drive.

    I may have tried other things too, but can't recall them at the moment. Any suggestions would be much appreciated.

    Thanks,
    Dean.
     
  2. richphoto macrumors newbie

    Joined:
    May 10, 2011
    #2
    Hmm, I have the same spec 3,1 late 2007 model and Granted I recently put in a new 7200rpm hybrid drive it has started up in about 1 min.
    has this machine been used hard? a 4 year old portable computer is pretty old, it could be something with the processor at this point.
    have you started in safe mode to see how long that takes?


     
  3. DSpiridonov thread starter macrumors newbie

    Joined:
    Aug 25, 2012
    #3
    It seems to boot within 2 minutes when entering into safe boot. The laptop belongs to the company i work for and is mostly used for documents (word, excel, etc.). It actually hasn't been used for a while since they've upgraded to newer Macs, but since there are volunteers, we need some older laptops fixed. This one and some others work fine once they've booted up, but the problem is starting them up.
     
  4. Idefix macrumors 6502

    Joined:
    Jul 10, 2012
    #4
    I'd try a clean install of Snow Leopard.

    Don't put anything else on until you've verified that startup is OK.
     
  5. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #5
    This sounds familiar.

    http://support.apple.com/kb/TS2377

    The computer may still be covered for a logic board replacement which should fix this issue and possibly the slow booting problem.
     
  6. zhandri, Nov 2, 2012
    Last edited: Nov 2, 2012

    zhandri macrumors 6502

    Joined:
    Sep 4, 2012
    Location:
    Germany
    #6
    yeah my mobo died because of that issue and apple didn't want to replace the mobo for free. they would have replaced it for 900 bucks. bought 1 from ebay for 300 and it works perfect now.

    my guess is. if you really want the laptop to run smoother upgrade the ram and buy a SSD. this will give you some nice performance boost
     
  7. fakiee macrumors newbie

    Joined:
    Jan 23, 2013
    #7
    My MacBook Pro 2009 Mid has teh saem issue. No matter what I boot from it takes an absolute age. tried different disk and still nojoy. booted from DVD and USb and it still takes a very long time (30min to get to login).

    Did you manage to resolve the issue? I have not tried safe mode yet.
     

Share This Page