MacBook Pro Eats My Password after Safe Mode / NVRAM/PRAM Reset?

Discussion in 'Mac Basics and Help' started by S-Harkey, Sep 8, 2009.

  1. S-Harkey macrumors newbie

    Sep 6, 2009
    I've been struggling all afternoon with a buggy mac. Heres EVERYTHING I have done, skip to the bottom if you don't care but I'm sure it matters:

    The problem started with crashes, I ran disk verify, got back that my HD was in need of repair. I tried to boot from the orig. install disks and could not (gray screen, continuous loading).
    I booted in verbose, I booted in safe mode, I tried running Sbin/fsck -fy, got back "Keys Out of Order (4, 7562) Rebuilding Catalog B-tree. The volume Macintosh HD could not be repaired" Tried again, same message with keys (4, 40696).
    Tried again, suddenly could no longer enter text in any kind of boot up.
    Could no longer reach my login on the computer now either, even without trying to boot with the disk.
    I reset the NVRAM/PRAM which got me past the gray screen and to blue screens. Tried to reboot regularly, no change, still blue screens. Tried to reboot in safe-mode, can't enter text still. Tried regular boot again and magically somehow got to the password screen?!!?!

    Great! I put in my password, but my computer does not accept. I am 100% POSITIVE that this is my admin password. I have NO doubts. Does NVRAM/PRAM reset the password somehow? Did one of the many other steps reset it?

    I tried to restart again after this and got gray screens again. I booted in Single-User Mode again and could enter text again so I ran:

    mount -uw /
    mv/Library/Preferences/SystemConfiguration/preferences/.plist preferences.old

    as says the apple support site. This got me back to the password screen again! But it still won't take my password! What??? Any help is appreciated!

    UPDATE: Suddenly safe mode is working again after a few attempts. I can login with my password in Safe Mode but a regular boot up says my password is wrong. Any ideas why?

Share This Page