MacBook Pro EFI Firmware Update 2.3 not working.

Discussion in 'MacBook Pro' started by caliberal91, Oct 29, 2011.

  1. caliberal91 macrumors newbie

    Joined:
    Oct 29, 2011
    #1
    I'm using a MacBook Pro, early 2011 model with Mac OS X Version 10.7.2. When I run Software Update, it alerts me that a firmware update is available, however every time I download and install the update, it prompts me to restart my computer. I do so, and every time it gives me a very audible noise and never restarts. After I manually restart, software update alerts me that the update is available. :mad:

    Anyone else having this problem?
     
  2. BreakGuy macrumors 6502a

    BreakGuy

    Joined:
    Nov 23, 2009
    Location:
    NZ, South Pacific
    #2
    'MacBook Pro EFI Firmware Update (v2.3)' not installing

    I've tried multiple times now to install this update. When I do, it downloads and my computer will restart around 5 times with the 'beep' the first time. Once its finished the restarts and resumes normally, I check the Software Update via the Apple menu and it still appears in the list of updates.

    What's the cause of this and what can I do to resolve this?
     
  3. kappaknight macrumors 68000

    kappaknight

    Joined:
    Mar 5, 2009
    #3
    How long are you waiting? Is your computer plugged in?
     
  4. getheo macrumors member

    getheo

    Joined:
    Jul 3, 2011
  5. Peace Freak macrumors newbie

    Joined:
    Jun 5, 2010
    #5
    I have the same problem and the computer is plugged in!

    Any solutions anyone?
     
  6. bhaveshc macrumors newbie

    Joined:
    Nov 2, 2011
    #6
    Same problem here

    I have early 2011 MacBook Pro and I am facing the same problem. It keeps showing me that the update is available even after downloading and installing it. Somehow the installation fails but there is no indication of this.
     
  7. koqenz macrumors newbie

    Joined:
    Nov 4, 2011
    #7
    I'm having the same issue. Early 2011 model 13" MBP. Reboot with audible noise, multiple reboots and update still outstanding.

    Tried both on batt and on power.

    WTF?
     
  8. ream88 macrumors newbie

    Joined:
    Nov 5, 2011
    #8
    Thank you, fixed it for me! :)
     
  9. psyscott macrumors newbie

    Joined:
    Sep 20, 2011
    #9
    My Win7 Boot Camp startup has complained it's counterfeit ever since the 2.2 EFI firmware update (even though it's perfectly legit booting under Parallels). That trouble left a bad taste, so I'll wait a while to see what problems this update brings. I don't want to lose Win7 under Parallels, too!
     
  10. macaddict06 macrumors regular

    Joined:
    Jan 17, 2006
    Location:
    about 3 meters from here. *points*
    #10
    Seeing the same problem here. Always update with my Early 2011 MBP (8,2) plugged in. Installed 2.3 update on 11/7 and again on 11/13. Both are showing up as "installed" in System Preferences.

    It's asking me to install again, and I'm debating whether or not I should do that. Clearly, it's installing the update (or perhaps not? Any way to check firmware version in System Info?), but is not registering it as such. Really irritating.

    Ideas?
     
  11. Jazojas12, Nov 17, 2011
    Last edited: Nov 17, 2011

    Jazojas12 macrumors regular

    Joined:
    Apr 24, 2009
    #11
    I have issues too..try to install then it restarts..then nothing. I have to hold down the power button then turn it back on. Can't remember if I had it plugged in so I'm going to try that right now and I'll update in a couple minutes.

    UPDATE: That seemed to have worked plugging it in. It had a message this time that said that but I don't remember seeing that before.
     
  12. Relievo macrumors newbie

    Joined:
    Dec 9, 2011
    #12
    I have this EXACT problem. My MBP is brand new today 09/12/11 (2.4ghz).
    You described my issue to a tee!
     
  13. Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #13
    It sees a hardware change and wants the key re-activated. Just re-enter the key and go through activation again.
     
  14. thermodynamic Suspended

    thermodynamic

    Joined:
    May 3, 2009
    Location:
    USA
    #14
    Agreed - there is no actual harm done.

    Even on PCs, updating the BIOS can trigger a reactivation.

    I've had to do that in the past, a number of times.

    The EFI is better than the BIOS in a number of ways, but its purpose is by and largely identical.
     
  15. apolloefx macrumors newbie

    Joined:
    Apr 10, 2012
    #15
    Same here.....MBA OCT 2010 Model 4GB RAM, bootcamp win7

    anybody knows why the update fails? cheers
     

Share This Page