Macbook Pro eternal problem of connection drops

Discussion in 'MacBook Pro' started by jcgnu, Oct 17, 2008.

  1. jcgnu macrumors regular

    Joined:
    Dec 30, 2006
    #1
    Hello,

    I have an Early 2008 Macbook Pro with Mac OS X 10.5.5. By the time I was running on 10.5.2 my Wi-Fi connection used to work perfectly, but when I updated to 10.5.3 I started to have so many problems with it that I even went back to 10.5.2 for a while.

    I remember posting a thread in a forum and people answered me that it was impossible for a software update to mess up my connection. I proved it by downgrading and gaining full connectivity back. I've also found hundreds of people who have been having the exact same problem, but it appears as if Apple just doesn't care enough to give a definitive solution. Instead, I've tried tons of other so-called solutions from other people, that have not done anything good for me.

    The problem is as follows: I can perfectly connect to my home network, but after 30 seconds- 2 minutes, my signal drops to just 1 bar (from full 4 bars) and I can no longer use it. To fix it, I have to disable my Airport card and then enable it back, to get another 30 seconds - 2 minutes. If I ever get to be connected for more than 2 minutes, my connection gets reaaaally slow (as slow that it can take me more than 5 minutes to download a 100 KB file).

    Anyway, I'm 100% sure this is a SOFTWARE issue since the same computer running on Windows and resting at the exact same place doesn't have a single problem connecting. Of course, it has nothing to do with my router configuration. It is completely, entirely, 100% a problem related to Mac OS X 10.5.3 and above.

    I love my computer in many ways, but this issue has been killing me bit by bit. What does a computer without a proper Internet connection work for? Then you can remotely understand my frustration.

    Please, if you have had the same problem post it here. Apple has to do something about this, because I can't believe I bought such a useless computer!

    Thanks.
     
  2. Anaxarxes macrumors regular

    Joined:
    Feb 27, 2008
    Location:
    Istanbul, Turkey
    #2
    Apple uses a non-Intel Wi-Fi card (Atheros) and Al material is not so good with wireless signals.

    But this could only lead to range problems, not connection drops.

    What protocol are you using? 802.11n/b/g/a ? If you're using "n" try setting your router to G only and try to connect like this. If it works, there you go you'll have internet, of course you'll loose the benefits of "n" but at leats thi can get you working again.

    I would go to an Apple store and explain the problem also. Maybe they can exchange your Airport card.

    P.S. Also try to look the Knowledge Base of your Router's support web site, maybe there is a problem issued with Airport cards on Mac, and this case Apple is not to blame.
     
  3. jcgnu thread starter macrumors regular

    Joined:
    Dec 30, 2006
    #3

    Thanks for your time to reply my message.

    Unfortunatedly, it is not a hardware-related problem, but a software one. As I said before, when I use Windows on the same machine, laying on the exact same place, my connection works perfectly. But on Mac OS X is where I have all these issues.

    I'm using 801.11g, so it should represent no problem. Also I've tried all kinds of configurations (WPA, WEP, No security, All channels, etc.) The problem persists.

    I can't go to an Apple Store since there are none in my country. And finally, this seems to be an issue that many many MBP users have had for a long time. It just seems like Apple hasn't done anything about it.

    Thanks again for your reply.
     
  4. jhamerphoto macrumors regular

    Joined:
    Oct 26, 2007
    #4
    The problem is with WEP configurations. A good friend of mine had the same problem, and called apple and told him to change to WPA, which fixed the problem.

    I have a Time Capsule set to Wireless N and a WPA configuration and it works perfectly, no dropped connection on a MBP.
     
  5. Phenobarbital4U macrumors newbie

    Joined:
    Jul 27, 2008
    #5
    I have the same problem. Also I have WPA, not WEP, so that can't be the problem. :S :(
     
  6. jhamerphoto macrumors regular

    Joined:
    Oct 26, 2007
    #6
    Weird. Maybe multiple things can cause the problem. In my friend's case, it was the WEP but it could perhaps be caused by multiple things.
     
  7. Phenobarbital4U macrumors newbie

    Joined:
    Jul 27, 2008
    #7
    yea i guess so :( i hope someone figures it out!! :confused:
     
  8. thespyglass macrumors regular

    thespyglass

    Joined:
    Aug 22, 2008
    Location:
    Liverpool UK
    #8
    Me too. That's a horrible problem, really hope we get a solution soon, guys. I was encouraged by the news that you could solve it by switching to WPA but if people are still having issues... :(
     
  9. jcgnu thread starter macrumors regular

    Joined:
    Dec 30, 2006
    #9
    Hello everyone...

    I think I just found a definitive solution to my problem and I'd like to share it with you all.

    If you read my first post (thread start) you will understand a little bit of my frustration. And I've tried all kinds of so-called solutions with no luck whatsoever. Those include all different configurations to my router (WEP, WPA, no security, different channels, varying the beacons interval, etc.), all configurations at my computer (resetting stuff, enabling or disabling functions, etc.) and again no difference whatsoever.

    As somebody suggested me I checked the messages on my Console and found that I was getting a message every 6 seconds that stated "Airport: Roam (Beacons lost)".

    After Googling it (or however it is spelled) I found another forum with a lot of people having exactly the same issue (http://discussions.apple.com/thread.jspa?messageID=8306094#8306094). Somewhere in the thread I read a post with something I didn't think would solve it. But, here's the solution:

    Turn off Bluetooth!!!!

    That's it! No more configurations, nothing else to do... Just turn it off and your connection will be back completely. And of course, turn off any other Bluetooth device nearby that could be causing the interference.

    Well, I don't know if it will work for everyone, but it sure fixed the problem I've been having for months.

    It's a shame I have to do it since I use a Bluetooth mouse and now I'm gonna have to stick to the trackpad (not to mention that I paid for this mouse). But I surely prefer a computer connected to the Internet than having a wireless mouse.

    After doing so, I still get a few of those "Beacons lost" messages, but only one every 5 minutes and my connections still works fine!

    I guess Bluetooth was causing interference since it uses the same 2.4 GHz frequency. I think it could also be fixed by upgrading to a 802.11n network at 5.X GHz. Still, I'm not gonna buy a new router and new wireless cards for all the computers.

    So, please, if you found this information useful and you problem was solved too, please post a comment to let us know about it!

    Thanks to all.
     
  10. radx macrumors newbie

    Joined:
    Oct 16, 2008
    #10
    I had similar problem after one of the airport updates. My SR mb started dropping link to my dlink g router like crazy, on any router settings.

    I solved the problem by getting a linksys draft N router. I suppose the problem is still there, I just avoided it.
     

Share This Page