MacBook Pro external display not working

Discussion in 'MacBook Pro' started by 1908, May 31, 2010.

  1. 1908 macrumors newbie

    Joined:
    May 31, 2010
    #1
    Hi guys, long time reader first time poster - I hope someone can help me =(

    So I went out and bought a new MacBook Pro 15" today in order to replace my aging 2.5 year old macbook (white) – also picked up a new mini displayport to dvi adapter as I had the my old macbook hooked up to my external monitor.

    All excited I plug everything in and I cant get the signal from my new 15" to the external monitor as it keeps saying no signal then just goes into sleep. I plug in my old ****** white macbook and low and behold it works again?

    Ive gone and got my brothers brand new 13" macbook pro to try as well and it does the same thing as mine?

    what could be wrong? Something Im missing here? Help

    cheers
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Maybe that adapter is kaputt, do you have any other mini Display Port to DVI adapter lying around to test the outputs of your MBPs?

    What input did you choose to use with the white MB? DVI or VGA?
     
  3. 1908 thread starter macrumors newbie

    Joined:
    May 31, 2010
    #3
    nah I havent got any other adapters of this sort lying around, the only other one that I have is the old external adapter that obviously is not around anymore since apple introduced the mini display port.

    with the white macbook I used DVI as is the same with this new mini display port.
     
  4. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #4
    Try this:

    With the monitor plugged in, go in your preferences pane, and select "displays."

    At the bottom there should be a "Detect Displays" button. Try clicking that and see if your external display comes on.
     
  5. 1908 thread starter macrumors newbie

    Joined:
    May 31, 2010
    #5

    Tried that lol but once I click it nothing happens. When I pull the mini display port plug out of my macbook pro the screen goes blue for a second (macbooks screen)
     
  6. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
  7. chopper dave macrumors regular

    Joined:
    Jul 23, 2007
    #7
    Make sure your computer is switching to the discrete graphics chip- if it is stuck on Intel then external displays won't work.
     
  8. 1908 thread starter macrumors newbie

    Joined:
    May 31, 2010
    #8
    How do I do that?
     
  9. smithrh macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #9
    Is your display open or shut?

    I've found that unless I have a power plugged into my MacBook, external video output won't work when the display is shut.
     
  10. 1908 thread starter macrumors newbie

    Joined:
    May 31, 2010
    #10
    tried both with no change - power is plugged in though
     
  11. tombilske macrumors member

    tombilske

    Joined:
    Jan 31, 2010
    Location:
    Australia
    #11
    go into energy saver and turn off automatic graphics switching. then try plugging it in and see if it works. if it does, then the problem is that it isnt switching to the dedicated graphics card automatically when u plug in the display. if that is the case then go into software update and make sure that you have the latest updates because apple released an update for your computer a just after it was released, that had something to do with the graphics switching. make sure you have that

    hope that works for you :)
     
  12. 1908 thread starter macrumors newbie

    Joined:
    May 31, 2010
    #12
    OK guys so I went and exchanged the mini display port adapter on the basis that i thought it was dodgy - turns out this was the problem all along and once I plugged in the new one it worked like a charm!

    thanks for everyones contributions =)
     

Share This Page