Macbook Pro External Display Question

Discussion in 'MacBook Pro' started by thouts, Jan 17, 2009.

  1. thouts macrumors regular

    thouts

    Joined:
    Jul 2, 2008
    #1
    Hello -

    I've got my unibody MBP hooked up to a 20" LG HDTV. It's hooked up from the mini display port to DVI adapter...then goes to a DVI to HDMI cable into my TV. It works but...the text and images just aren't anywhere near as clear as they are on my MBP's display...is there any way to fix this or is it just how it is?
     
  2. kastenbrust macrumors 68030

    kastenbrust

    Joined:
    Dec 26, 2008
    Location:
    North Korea
    #2
    Try changing your Macbook Pro to its maximum screen resolution before connecting it to any external display/projection devices. This is a common issue.
     
  3. thouts thread starter macrumors regular

    thouts

    Joined:
    Jul 2, 2008
    #3
    It was on maximum resolution...
     
  4. Hydroxs macrumors regular

    Joined:
    Jun 25, 2008
    Location:
    Tuscaloosa
    #4
    Are you mirroring the screen? If so it uses the maximum resolution on the smallest screen. Turn off mirroring or use it in clam shell mode.
     
  5. jfriedman8 macrumors 6502

    Joined:
    Feb 8, 2008
    #5
    I had the same thing happen with my Gateway 24" monitor. Instead of using a DVI to HDMI, i just used a DVI cable and it came out fine. To my knowledge, there is no point in having the DVI to HDMI since you cant get the audio signal on a mac. Of course it's nice to just have a smaller thing to plug in (why I tried it in the first place) but the DVI works much better.
     
  6. thouts thread starter macrumors regular

    thouts

    Joined:
    Jul 2, 2008
    #6
    The screen is not mirrored...hope I dont' have to get a new cable...anybody have any other suggestions??
     
  7. xavious85 macrumors newbie

    Joined:
    Jan 17, 2009
    #7
    I had this problem and figured out a remedy. The reason stuff isn't looking clear is because your TV's native resolution is to display at a higher resolution that the laptop screen can display. So what I usually have to do is:

    -plug up my laptop to external power (if you don't do this, it will turn off when you close the monitor again)
    -plug the external monitor up
    -close the mointor for it to go to sleep
    -wake it up by opening the monitor but closing it before it displays to the laptop monitor and there you go, displaying at the correct resolution on your TV.

    -You can also wake it up if you have a USB keyboard, just hit a few keys on the keyboard to wake it up when the screen is closed.
     
  8. thouts thread starter macrumors regular

    thouts

    Joined:
    Jul 2, 2008
    #8
    I've tried all of these suggestions...no luck. I'm starting to think this is just how it is...maybe because it is a TV? Does it have to be a monitor with a certain resolution or something...I'm lost?
     
  9. Migsy macrumors newbie

    Joined:
    Jan 19, 2009
    Location:
    London, UK
    #9
    By the sounds of it, you need to disable Overscanning

    On my Sony TV, this option is called "Full Pixel", I think other TVs call it 1:1 Pixel Mapping or simalar. Not all TVs have this option.
     

Share This Page