Macbook Pro fades to black on login

Discussion in 'macOS Sierra (10.12)' started by Dave00, Jan 6, 2017.

  1. Dave00 macrumors 6502a

    Joined:
    Dec 2, 2003
    Location:
    Pittsburgh
    #1
    I thought I would post this here, as this is a problem that has been driving me NUTS until I found a solution.

    After booting, you get the normal login interface. After logging in, the process starts, then fades to black. You still get the arrow cursor but that's it. Notifications, strangely, will still appear, though very faded. It almost seems like the brightness is turned down too low, except that the arrow cursor is a normal appearance.

    My system is a 2012 rMBP, with an upgraded 3rd-party 1GB SSD. Had no problems until updated to Sierra 10.12.2. All of the usual fixes failed - PRAM, hard drive checks, fsck, etc. - and same problem would occur booting into Safe mode.

    Here is the fix that finally worked. You have to boot into single-user mode (boot with Cmd-S held down). Once you get a command line, type

    rm -f /Library/Preferences/com.apple.loginwindow.plist
    reboot

    This fixed the problem for me.

    Dave
     
  2. dloreski macrumors member

    Joined:
    Feb 5, 2009
    #2

    I just had this problem on my 11" Air.
    While the faded screen is on with the bright cursor, I typed the first letter of my username, hit enter, typed my password, hit enter, and everything came up normal then. (You can't see anything on the screen while typing this).
    I've only rebooted once since this issue and it worked again.
     

Share This Page