Macbook pro going slow

Discussion in 'MacBook Pro' started by eddy401, Nov 16, 2011.

  1. eddy401 macrumors newbie

    Joined:
    Nov 16, 2011
    #1
    I searched the web about 2 hours trying to find any solution or what i am doing wrong.
    I like to play games on my mac now and then. my mac supports enough for me, i know its limitations. But my problem is this. I have a game called Trine, i played it yesterday for a couple of hours, it was good. no lagging or anything. but today i tried again and it was freakish! this happened to me before and i reinstalled my os because i couldnt find any answer and it got better. it was about 2 months ago and it started again.
    I have a 2010 macbook pro with 4 gb ram 450gb hdd (currently 400 is free) and intel hd graphics with 512 and nvidiva 330m with 288 vram.

    is something working wrong? or is it something else?
    ps; my mac has been open for about 3 days today. a little bit hot (52 C). is it because of that?
    i dont think it is because as i said, i had this problem before. before reinstalling my os. I though that this was because it was open all the time so i tried closing it for a day and opening it but i remember this happening again.
    so...
    any thoughts? any suggestions?

    Thank you
     
  2. Mersailios macrumors regular

    Joined:
    Oct 23, 2011
    #2
    Have you installed any software updates recently (in the past few days)?
     
  3. eddy401 thread starter macrumors newbie

    Joined:
    Nov 16, 2011
    #3
    ye i believe my mac is up to date. probably done it 1 week ago. why? is there something wrong? btw i wrote it wrong. it was hd graphics 288 mb and nvidiva 512 vram.
     
  4. eddy401 thread starter macrumors newbie

    Joined:
    Nov 16, 2011
  5. miniConvert macrumors 68040

    miniConvert

    Joined:
    Mar 4, 2006
    Location:
    Kent, UK - the 'Garden of England'.
    #5
    So previously the game played completely fine, but now when you try it it's immediately poor?

    Does it make a difference if you're on mains power or battery?

    Perhaps the GPU isn't switching or something? I've not yet had a dual GPU MBP so I'm not really sure how that works. Perhaps try a full shutdown, then power up and try the game again.
     
  6. eddy401 thread starter macrumors newbie

    Joined:
    Nov 16, 2011
    #6
    ye, i dont know if gpu is switching or not. but when i close and open it up again 10 minutes, its okay but after 10 minutes same thing happens. doesnt matter if its on battery of power adapter. this is really bugging me off.
    i have a nice mac but the few games i play, one of them is minecraft and even that is laggy. this is not a good sign i guess.
    anyone have an idea?
     
  7. windowstomac macrumors regular

    Joined:
    Jun 23, 2011
    #7
    SL or Lion? My MBP slowed significantly after Lion until I increased ram to 8gb
     
  8. eddy401 thread starter macrumors newbie

    Joined:
    Nov 16, 2011
  9. miker2209 macrumors regular

    miker2209

    Joined:
    Jan 2, 2010
    #9
    Try reseting the SMC, maybe theres something wrong with the graphic switch and while you're it switched from the 330m to the intel HD and make the game lag.
     

Share This Page