Macbook Pro hangs after login

Discussion in 'MacBook Pro' started by Freakk123, Feb 16, 2009.

  1. Freakk123 macrumors regular

    Joined:
    Feb 19, 2003
    Location:
    Bronx, NY
    #1
    About a week ago my MBP seemed to be running slow so I decided to restart it. It refused to properly boot up, though. It seemed to be booting fine (if, maybe, a bit slow) till after I logged in. My background loaded, as did my desktop icons (aside from the Macintosh HD icon, but the text loaded), but nothing would open and I couldn't open any finder windows.

    The problem has remained essentially the same, changing slightly at times, but it is still essentially identical. There was a period when nothing loaded, not even my background, but that passed. Currently, it sort of varies between loading everything but the menu bar and loading everything but the Macintosh HD icon. I can't open anything, and external harddrives refuse to show up. However, when I unplug external hdd's I get the standard "You removed something without ejecting it" message.

    I have tried to boot from my Leopard disk, but to no avail; the disk spins, there is a clicking sound from the drive and then it's ejected. The same happens when I put a disk in after I've logged in. I have also tried using different ram and resetting the PMU, but to no avail.

    Any advice or suggestions would be greatly appreciated, I really need to be able to use my computer and access the data on it. Bringing it to an Apple Store isn't really an option because I'm at my college and the closest Apple Store is 40 minutes away, and I don't have a car.

    Thanks.
     
  2. NZLou macrumors newbie

    Joined:
    Feb 16, 2009
    #2
    Similar Issue

    Hi I also had the problem with my MBP hanging on start up. As I went through the issues with Applecare I found out that my FW was inop, hardware issue. This is the second MBP that I've had inside a month that has had the same issue. I got both of them at MacMall. Applecare is having it returned for repair. I'm still baffled why I have two with the similar issues. I used an Oyen Digital 250G FW drive that has worked OK until it came time to access time machine.
     
  3. macbookairman macrumors 6502a

    Joined:
    Jan 15, 2008
    Location:
    United States
    #3
    Have you tried repairing permissions? Also, you may want to install the 10.5.6 combo update, which in my experience helps my system run better.
     

Share This Page