MacBook Pro hard drive upgrade problems

Discussion in 'MacBook Pro' started by Eric Sadoyama, Oct 19, 2007.

  1. Eric Sadoyama macrumors newbie

    Joined:
    Aug 14, 2006
    Location:
    Honolulu
    #1
    I tried to upgrade the hard drive on my 2.0Ghz Core Duo MacBook Pro and something went wrong. Here's what I did:
    1. Used SuperDuper! to make a bootable copy of my system onto a Western Digital 160GB Passport external drive.
    2. Opened up the MBP and removed its factory-installed Fujitsu 80GB drive, using the instructions at ExtremeTech.
    3. Popped open the Passport's plastic case and removed the WD Scorpio drive inside.
    4. Moved the MBP mounting hardware from the Fujitsu to the WD, attached the SATA cable, and put the WD into place.
    5. Closed everything up, put the battery back in, and powered up.
    But the MBP didn't go BONNNGG at startup like it's supposed to do. Instead, I could hear something whir (a fan?) and the little white LED on the latch-release button started blinking quickly... but that was it. Nothing else happened.

    The only iffy thing that came to my mind was that I saw that the WD had a jumper on its pins 1-2. I looked at the MBP's Fujitsu and it didn't even have pins to place a jumper on -- so I wasn't sure what to do. First, I removed the jumper and installed the WD without it. Then, after the MBP didn't power up properly, I took everything apart, put the jumper back on, and put it all back together again, but the MBP still didn't power up so I am not sure if that made any difference.

    That's all I was able to get done last night. The next thing I plan to do is put the original Fujitsu back in and try to restore the MBP to its original condition and verify that nothing is actually damaged. Also, I didn't check the SuperDuper! copy on the WD; I plan to put it back into its external case and try booting from it as an external drive.

    What does the blinking white LED indicate, anyway? And what might I have done wrong? Any ideas? Help!
     
  2. squeeks macrumors 68040

    squeeks

    Joined:
    Jun 19, 2007
    Location:
    Florida
    #2
    not sure what the blinking LED might indicate, but did you check to make sure everything was connected securely?

    The jumper should be left where it was, but either on or off i dont think itll make much diffrence, i dont remember what the jumper on that drive does anyway, it should tell you on top of the drive what its for.

    also, try resetting the PRAM

    (google "resetting pram")

    hope that helps
     
  3. TheStu macrumors 65816

    Joined:
    Aug 20, 2006
    Location:
    Carlisle, PA
    #3
    Also, and I am not positive about SuperDuper, but CCC has a box (at least it used to) to make the drive bootable, if you neglected to do that, then that could be your problem.
     
  4. Hockeypuck macrumors regular

    Joined:
    Sep 29, 2006
    #4
    Blinking lights tend to be memory errors. Try reseating the RAM
     
  5. Eric Sadoyama thread starter macrumors newbie

    Joined:
    Aug 14, 2006
    Location:
    Honolulu
    #5
    Problem solved. When I put the RAM modules back in, I didn't seat them deeply enough, so they were loose. I re-seated them and everything works now. Hooray!
     

Share This Page