Macbook Pro i7 15" (Mid-2012) No Backlight

CasaOui

macrumors newbie
Original poster
Jun 6, 2014
5
0
Hello everyone,

I have this problem for over 2 moths and after searching the entire web for answers (youtube, macrumors, google etc) but with no success.

The problem is that I had a wine accident with my MacBook Pro mid-2012 15" (A1286 EMC 2556). After this accident I've immediately disassembled the MacBook and cleaned the logic board with Isopropyl alcohol (96%) let it dry for two weeks while waiting for the new keyboard since I'm sure the keyboard takes the most damage in this cases. I also changed the cable (screen).

So after two weeks I've received the keyboard and re-assembled the MacBook. Everything worked perfect for almost a week and after that the screen would turn black and stay that way until I restart the machine and again the same thing happens over and over.

after a few days the MacBook powers up and play the apple sound but the screen stays black. With a flashlight I see the Apple Logo and after a while I can see the background (of my two kids) so the MacBook does power up and loads the OS, but nog backlight.

I did a lot of searching just to find out where the responsible backlight inverter is or ic or chip or schematics, but no answers on the net. I do have experience with electronics and replacing things and also have the right equipment (rework/reballing/soldering station) but no idea what I should replace.

I hope someone here can help me trough this. I've attached some pics of my logic board.

Thanks
 

Attachments

Last edited:

CasaOui

macrumors newbie
Original poster
Jun 6, 2014
5
0
Just to be sure I did buy a new cable. I still have the originele cable and I've tested both and still no backlight.
 

donglory

macrumors newbie
Sep 8, 2016
2
0
Accra Ghana
Just to be sure I did buy a new cable. I still have the originele cable and I've tested both and still no backlight.
I had my backlight not working also. this is what i did after checking most component i realised the inverter Ic was not receiving power so i used a thin cable to bridge power to one leg and the light started working. hope it will work for you too
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.