Macbook Pro issue with playing .MKV files

Discussion in 'MacBook Pro' started by Charlie03, Aug 24, 2010.

  1. Charlie03 macrumors newbie

    Charlie03

    Joined:
    Aug 24, 2010
    Location:
    Dallas, TX
    #1
    I am having an issue that recently started and maybe someone can point me in the right direction. For the last month or so I can no longer watch movies that are .MKV on any application. I was using XBMC, Boxee, PLEX, VLC etc and all of them did work at one point and time but recently my macbook pro connected to my HD TV via DMI to HDMI will not play the movies properly. The movies will either play choppy where they are off from the sound and video when using XBMC, Boxee or Plex. When using VLC they are pixelated the whole time really hard to see anything. I had taken my laptop to the apple store to have the CD/DVD drive replaced and mentioned this to them to which they said they did not find anything wrong. I was thinking maybe it was graphics card related. So the genius there told me to reinstall the OS and to only use "Apple supported" files/movies. So i did reinstall Snow Leopard on the machine but the problem still continues. I have tested it by using shows/movies in M4V format from apple playing it through Itunes and have not seen the issue with the video. Anyone have any ideas of what it could be that caused/is causing this issue? Any help would be greatly appreciated.

    I am running a 2008 17" macbook pro w/a 2.4 GHz, 4GB RAM, 160 GB HD, OS is 10.6.4 with all the latest updates. All my movies are housed in my 2TB external HD "My Book" but also i have tried to transfer them directly to my macbook pro HD which does nothing to correct the issue.
     
  2. UbuntuFu macrumors regular

    Joined:
    Aug 16, 2007
    #2
    Doubt it's the video card. Plex by default uses CPU decoding.
    I had a mac mini 2ghz c2d with only 1gb ram, 128mb video and it played 16gb MKV files just fine.
     
  3. hleewell macrumors 6502a

    Joined:
    Oct 22, 2009
    #3
    I am sorry to hear your problem but my friend who has a lower spec-ed laptop: a 2008 MacBook unibody with 2.0 Ghz Core 2 Duo + 4 GB RAM + nVidia 9400 Integrated chip, could play almost all kinds of video format (incl. the now defunct .rm files) with VLC with the exception of 1080p vidoes. PLEX handles 1080p mkv file even better than VLC. All Quicktime trailers 720p & 1080p play flawlessly. Maybe you should download the latest VLC or PLEX and try again.
     
  4. Charlie03 thread starter macrumors newbie

    Charlie03

    Joined:
    Aug 24, 2010
    Location:
    Dallas, TX
    #4
    Thanks for the reply guys. I actually never had a problem with any large movie file playing on my macbook pro. This as indicated is very recent problem. I had gone ahead and made sure all my programs I tested were up to date. I have the latest versions on VLC, Plex, Quicktime, I even installed Quicktime 7 from the DVD install disc and tested my old Quicktime Pro license to test this out. I am taking it in to have it looked at/repaired Thursday by Apple. While doing some research on this model with the graphics card I found an article on Apples website.

    http://support.apple.com/kb/TS2377

    In the article it did indicate that NVIDIA publicly acknowledged a higher than normal failure rate for some of their graphics processors due to a packaging defect. At that same time, NVIDIA assured Apple that Mac computers with these graphics processors were not affected. However, after an Apple-led investigation, Apple has determined that some MacBook Pro computers with the NVIDIA GeForce 8600M GT graphics processor may be affected. If the NVIDIA graphics processor in your MacBook Pro has failed, or fails within four years of the original date of purchase, a repair will be done free of charge, even if your MacBook Pro is out of warranty.

    These computers were manufactured between approximately May 2007 and September 2008

    I bought mine Early Jan of 2008 and I called apple tech support just to be sure. The technician I spoke with said to go ahead and have them replace the graphics card to see if this would resolve the issue. I am hoping it does since I do love hooking up my macbook pro to my TV and being able to use my remote to watch all the movies and shows. I recently disconnected my satellite service and I am down to only having to pay for internet. So far so good I was always scared to cut the cord but it's been the best money saving investment I have made so far.

    Hopefully if anyone else runs into this problem and runs into this might be helped out by the article included in the link. I will update this to let you know what happens after getting the graphics card replaced.
     
  5. Charlie03 thread starter macrumors newbie

    Charlie03

    Joined:
    Aug 24, 2010
    Location:
    Dallas, TX
    #5
    You guys were right it was not the graphics card but it was the logic board that was failing. Of course that caused the issues with the graphics card not responding properly. So as of right now it is being replaced and hopefully this corrects all the issues I've been having with playing my movies.
     
  6. macbookuser19 macrumors newbie

    Joined:
    Nov 7, 2008
    #6
    VLC Player solution from 2008

    Hi all, I have recently had my NVIDIA chip replaced by Apple, and was still getting the dreaded video frame drops and plenty of video crashing! I have just tried the solution highlighted in the following URL:

    http://www.chipmunkninja.com/1080p-MKV-playback-on-Mac-1r@

    It worked for me, and have managed to load up one of my home videos which weighed in at a whopping 7gb, smooth with no issues. Watched the whole thing, and best of all I was able to use the slider without it crashing on me! Good luck! :cool:
     
  7. Calculon macrumors newbie

    Calculon

    Joined:
    Mar 26, 2011
    Location:
    The Future
    #7
    Try this FIRST

    The link supplied is not an ideal solution, as you lose frames of the movie.
    I recently had a choppy playback issue with a .mkv file, however using VLC, I was able to tweak a preference which fixed the problem outright.
    This will only solve the playback from a file on your hard disk.

    Go to Preferences (⌘,) click All preferences in the bottom left corner.
    - select Input/Codecs, then within that, Access modules, and finally within that, File.
    - change the Caching value (ms) to 800.
     

    Attached Files:

Share This Page