MacBook Pro issues after 10.6.6

Discussion in 'MacBook Pro' started by capitanbuzo, Jan 6, 2011.

  1. capitanbuzo, Jan 6, 2011
    Last edited: Jan 6, 2011

    capitanbuzo macrumors 65816

    Jul 17, 2007
    Not sure if this is the right forum or not but after I installed 10.6.6 on my MacBook Pro mid 2010 a lot of my applications are not functioning properly. Firefox crashes constantly (though redownloading it seemed to fix it) but my main issue is that iTunes does not work. First, it lost the XML file for my library. After reinstalling iTunes and recovering the XML file from a backup, it will now load but constantly crashes after about 20 seconds. My Mac Pro doesn't have any of these problems while running 10.6.6. Any ideas?

    Edit: it says the Library was damaged so, again, I am trying to get an older file to fix it. Anyone else having issues like this after 10.6.6?

    Edit #2: Now it will not let me go and recover files from Time Machine. Notnsure what thisnupdate has done to my computer.
  2. Squadleader macrumors regular

    Jun 16, 2010
    Avalon Hill
    I havnt had any probs...Is it possible to go back to an earlier version (Time Machine..??) then re-install the latest..??
  3. jsoto macrumors regular


    Jul 27, 2010
    I have the same model as you. I just updated & everything worked fine. I did have to do a restart so the Mac App Store would allow me to install apps. I also had to accept the new license from EULA from iTunes. After all that was done everything worked with no issues. I am on a mid 2010 MBP i7 just over a month old.
  4. capitanbuzo thread starter macrumors 65816

    Jul 17, 2007
    Well I keep going back to try to restore my iTunes to a later time but it is still not working. I might try exporting my Mac Pro's library (it is similar but not identical) and see if that works.

    Edit: Forgot to mention that my iStat pro widget disappeared as well.
  5. CW Jones macrumors 6502

    Nov 24, 2009
    Sounds odd... I am having no issues with itunes and I have been running it literally for the past 8 or so hours.
  6. capitanbuzo thread starter macrumors 65816

    Jul 17, 2007
    Well, can't seem to figure out how to get my iStat pro back working. I am now using my library file from my Mac Pro son that fixed iTunes but now I must sort out files I don't use. Rme Machine seems not to be working correctly. I think it is going to try to backup my entire machine and ignore the previous backups I have. Not exactly sure what is going on but I am not so pleased with my MacBook Pro right now.
  7. capitanbuzo thread starter macrumors 65816

    Jul 17, 2007
    Too much seems to be messed up. Luckily I should have everything on my external or my Mac Pro. I guess I am going to go to my two week old backup to fix this thing. I'm still notnsure exactly what has happened though.
  8. jsilas macrumors regular

    Dec 6, 2010
    Washington State
    Mid-2010 MBP here - no issues whatsoever after 10.6.6 update - in iTunes or otherwise.

    Hope yours get sorted out mate!
  9. capitanbuzo thread starter macrumors 65816

    Jul 17, 2007
  10. budman1961 macrumors regular

    Mar 9, 2010
    DOS isn't don until Lotus wont run.......oldtimers remember this!
  11. firewalker746 macrumors newbie

    Dec 24, 2010
    10.6.6 problems

    I'm having a number of issues including,

    1. Apple Remote Desktop not starting (Apple just quietly updated the update for 3.4)

    2. TimeMachine will no longer load. It hangs itself and Finder. Restoring is currently impossible unless I do a complete restore booting from the install disks.

    3. A couple non-apple apps that have worked for years no longer start or hang.

    4. Some of my automation scripts have stopped functioning.

    5. Over all there is a noticeable system wide sluggishness that did not exist before the upgrade.

    6. Lastly when opening a number of programs Finder hangs and must be restarted.

    WTF is the deal? SO SORRY I did this update.
  12. NazgulRR macrumors 6502

    Oct 4, 2010
    What I have noticed is that uTorrent silently closes on its own - no errors whatsoever. :S
  13. djasterix macrumors 6502a


    Apr 10, 2010
    Paradise City
    No issues in here, everything working just fine...
  14. Blu101 macrumors 6502a


    Sep 10, 2010
    No issues here as far as I can tell, everything works...

    Can you take it to an apple store for them to check it out?
  15. Vantage Point macrumors 65816

    Mar 1, 2010
    New Jersey
  16. koolrosh macrumors newbie


    Nov 29, 2009
    EDIT to my original post:

    I've found that when the graphics is being switched from the intel to nvidia card on my mbp my wallpaper disappears and turns just into a solid blue color.

    have gfx card status, so i can see the switch and often when it happens the desktop background disappears. Anyone else have this issue?
  17. docal97 macrumors 6502a


    Jun 28, 2006
    No issue here. Flawless installation. Could it be your machine?
  18. firewalker746 macrumors newbie

    Dec 24, 2010
    Re: 10.6.6 problems

    It looks like the culprit is the 3rd party memory I put in some time back to bring my MBP up to 8GB. This was never an issue before 10.6.6.

Share This Page