Macbook Pro Kernel_task over 300%

Discussion in 'MacBook Pro' started by kingskie, Oct 7, 2016.

  1. kingskie macrumors newbie

    kingskie

    Joined:
    Oct 7, 2016
    Location:
    indonesia
    #1
    Hello,

    I am a newbie here..please help me.

    I am doing repair for Macbook Pro A1278 (APPLE A1278 820-2936-A).

    these are the sympthoms:
    1. when turn on the macbook i have to push the power button until the chimes sound if not it can not be turn on.
    2. after turn on the macbook is very lagging. so when i check the activity monitor it shows kernel task over 300%.

    so i tried some action:
    1. reinstall the mac os x -- nothing changed
    2. change the battery -- nothing changed
    3. take out all the connector (wifi, speaker, dvdrom) -- nothing changed
    4. try to safe mode boot - kerner_task below 50% and no lagging.
    5. try to do AHT -- shows error 4SNS/1/40000000:IB0R-9.166
    6. try to measure the U5400 --it shows 0V at pin 6.

    P.S. this macbook pro has no water damage

    Help me please.

    FD
     

    Attached Files:

  2. kingskie thread starter macrumors newbie

    kingskie

    Joined:
    Oct 7, 2016
    Location:
    indonesia
  3. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #3
    From googling, it appears that the error code quoted is a logic board sensor error. I think your logic board needs to be repaired or replaced. This does not sound like a software problem.
     
  4. kingskie thread starter macrumors newbie

    kingskie

    Joined:
    Oct 7, 2016
    Location:
    indonesia
    #4
    thank for reply JohnDS.
    i know this is logic board problem that is why i need help to repair it. can somebody assist me?
     
  5. iMacC2D, Oct 10, 2016
    Last edited: Aug 12, 2017
  6. kingskie thread starter macrumors newbie

    kingskie

    Joined:
    Oct 7, 2016
    Location:
    indonesia
    #6
    thanks for the reply iMacC2D.

    i really confuse about the 820-2936 boardview i have. in boardview i can see there are U5420 and U5421 but phisically on the logicboard there is no present for U5420 and U5421. i can only see the path as i attached the image.

    can you help to share your schematic file and boardview for this type?
     

    Attached Files:

  7. iMacC2D, Oct 10, 2016
    Last edited: Aug 12, 2017
  8. kingskie thread starter macrumors newbie

    kingskie

    Joined:
    Oct 7, 2016
    Location:
    indonesia
    #8
    what do you think i should do now iMacC2D?
    i really confuse
     
  9. iMacC2D, Oct 11, 2016
    Last edited: Aug 12, 2017

Share This Page