MacBook Pro keyboard stopped working

Discussion in 'macOS' started by bmwmcrider, Feb 28, 2008.

  1. bmwmcrider macrumors newbie

    Joined:
    Jan 4, 2008
    #1
    Hello,

    Yesterday I had a Leopard software update which included new keyboard firmware. I did the update and the keyboard continued to function normally. This AM I booted my MacBook Pro and discovered the keyboard no longer responds to inputs. However, the MB does responds to an external USB keyboard.

    Now I don't know if I have a sudden hardware problem or the MB keyboard is not working as a result of the firmware update. Has anyone else experienced a similar problem? Can I go back to the earlier revision of the keyboard firmware?

    Mike

    Hmmm - while writing this I just realized I have a bootable image of my system made a few week back on an external drive - I'll have to try it.
     
  2. falslev macrumors newbie

    Joined:
    Mar 7, 2008
    #2
    I have the same problem and i can't find any fix any where.

    Some body help.
     
  3. bmwmcrider thread starter macrumors newbie

    Joined:
    Jan 4, 2008
    #3
    Hello,

    Just read your post - you will probably have to send your MacBook Pro back to a repair center. In my case the keyboard logic board had to be replaced. It was just coincidence that it failed about the same time I downloaded and installed a keyboard firmware update. Also, I want to note that my trackpad was not working either.

    Mike
     
  4. mweitzel macrumors newbie

    Joined:
    Mar 26, 2008
    #4
    Keyboard update and then internal keyboard and trackpad stopped working...

    Hhmmm... sounds like hell of a coincidence that my internal keyboard and trackpad stopped also working after a keyboard update that was applied.

    (Actually this smells of something steamy, brown and smelly!)

    Mike.
     
  5. jct4jc macrumors newbie

    Joined:
    Apr 4, 2008
    #5
    keyboard firmware update 1.0 froze my keyboard and trackpad!

    I downloaded the keyboard firmware update 1.0 this morning and now my keyboard and trackpad are frozen! Clearly this is a problem experienced by quite a few as I've read it in the forums a few times already, but no one seems to be able to give us a solution! I tried manually installing it, but it keeps saying "Your keyboard does not need this update, your machine already has this functionality". What do I do about that? It won't let me do anything!

    Please help!!!
     
  6. mweitzel macrumors newbie

    Joined:
    Mar 26, 2008
    #6
    More information (still not fixed)

    Took my MacBook Pro to the local Apple shop to let the 'experts' have a look at it. Between themselves they were allowing the fact that the update might have caused the problem (even though they wouldn't say so to me). They said the keyboard needs replaced.

    Here is some more information, this is an extract from the update log on my machine:
    2008-02-14 16:21:46 +0000: Installed "Leopard Graphics Update" (1.0)
    2008-02-22 11:13:34 +0000: Installed "Keyboard Firmware Update" (1.0)
    2008-02-22 12:48:41 +0000: Installed "Keyboard Firmware Update" (1.0)
    2008-02-22 12:49:24 +0000: Installed "iTunes" (7.6.1)
    2008-02-25 12:49:54 +0000: Installed "Keyboard Firmware Update" (1.0)
    2008-02-29 11:05:44 +0000: Installed "Keyboard Firmware Update" (1.0)
    2008-03-10 16:22:02 +0000: Installed "Aperture Update" (2.0.1)
    2008-03-10 16:22:18 +0000: Installed "Keyboard Firmware Update" (1.0)
    2008-03-17 16:13:39 +0000: Installed "Keyboard Firmware Update" (1.0)
    2008-03-17 16:14:08 +0000: Installed "AirPort Utility" (5.3.1)

    Clearly shows that the same update was applied 6 times, strange no? After the last time the keyboard and trackpad stopped working. I don't necessarily think that the keyboard needs replaced (even the keyboard lighting is working properly). In VMware Fusion the Trackpad shows now up as a USB device "Internal Apple Trackpad Programmer" which it never used to. It looks like the firmware is in a write state which probably disables the functionality. Also had tried to apply the update manually again but got the message that the keyboard doesn't need the update. All looks like the hardware is still responsive to the system just that the user interaction is disabled (as said probably to write an update to the firmware).

    Does anybody have an idea how to get the keyboard/trackpad out of that state??
     
  7. bmwmcrider thread starter macrumors newbie

    Joined:
    Jan 4, 2008
    #7
    To mweitzel:

    Please post what the resolution to you problem was. As I had stated in my earlier post I wound up by sending my MacBook Pro back to a repair center. The repair order shows that they replaced keyboard/trackball logic board. Of course that is the easy out. If indeed the firmware update did leave the keyboard/trackball processing in a state such that it would not respond to user inputs the repair technicians would, in all probability, not trouble shoot this possibility. It easier and more cost effective to replace a piece of hardware.

    Good luck.

    Mike
     
  8. jct4jc macrumors newbie

    Joined:
    Apr 4, 2008
    #8
    My solution today was at the Genius Bar. They tried a number of different things like resetting PRAM etc, but it didn't work. So they told me to come back in an hour, they replaced the keyboard, and voila! Done! So lucky it was within warranty, Apple care is so expensive.
     
  9. scotty588 macrumors 6502

    Joined:
    Jan 2, 2007
    Location:
    Carlsbad, CA
    #9
    I had this happen as well but it was when I installed Leopard and my trackpad crapped out also. Brought it in and they replaced the keyboard and topcase. Not under warranty and no Applecare so it cost me $300. Works fine now.
     
  10. mjrmd macrumors newbie

    Joined:
    Apr 6, 2008
    #10
    Three new MBPs with non-functioning keyboards

    When I received the first of 3 Feb08 MBPs this week. I transferred an image of my Jun07 MBP with a Firewire 800 cable directly from the previous machine, as suggested by the Migration Assistant. Everything looked correct. When I downloaded the latest updates I was asked to enter my Admin password. There was a blinking cursor in the appropriate field, but using the keyboard no type appeared. I tried plugging in my aluminum Apple keyboard, no improvement. I changed my startup disk to a very recent bootable clone. (It was a SuperDuper! image on an external drive that is updated daily and frequently used as an alternative boot drive, so I know it worked.) Still neither keyboard worked.

    Figuring that I got a dud, I called customer service at MacConnection and they sent another machine overnight. Going through the same sequence I got the same result, except the USB keyboard worked. It seemed unbelievable. When I called again I was passed over to their tech support and he had no idea, except to take it to an Apple store for repair. They were gracious enough to overnight the third MBP.

    When the third machine arrived I decided to not use the Migration Assistant. It recognized my AE router and asked for the password. Voila, this keyboard worked. Then I went back to the Migration Assistant and transferred the image from my external drive. Drat! the problem was back. Using the Installation CD and repairing permissions and the disk was no help.

    It seemed that there was some “conflict” between whatever was on the bootable clone and the new MBPs or that there was a corrupted file on the clone, though it has always worked as a startup drive before.

    I decided to try another approach. I reinstalled the OS with an Erase and Install and installed 30 GB of Apps, Docs, etc. manually. It worked.
     
  11. mweitzel macrumors newbie

    Joined:
    Mar 26, 2008
    #11
    Solved: User error(?)

    Hi guys...

    I got my problem fixed now, which looks like it was due to user error. :eek:

    When I installed the keyboard update (from memory) it looked like it was going through alright. This morning I needed to access an application in my Utilities folder when I noticed an application I hadn't noticed before: "Built-In Keyboard Firmware Update"

    Thought to myself let's give this a try and when the application had finished executing I rebooted the system et voila... my internal keyboard and trackpad were working again.

    Sorry for the fuss!
     
  12. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #12
    It probably is best to run Software Update for at least the OS, and then run it again for any followup Firmware on a new Mac before you ever wipe the drive or load a different image. That way, it is able to get itself up to date without confusion.
     
  13. ella138 macrumors newbie

    Joined:
    Sep 7, 2008
    #13
    Same thing happened to me. I searched the internet for an answer and found none. I took my Macbook Pro to an apple store where they replaced the topcase and the keyboard (I have an applecare warranty) and it's been a couple of weeks now and the problem is gone. So it is a hardware problem.
    It is an expensive fix. The topcase alone is $400, so if you have a warranty it would pay for itself.
     
  14. omegabane macrumors newbie

    Joined:
    Feb 13, 2008
    #14
    Temporary Fix

    I had these same problems, but didn't want to spend the money to repair it. I was out of both Warranty and AppleCare.

    An external mouse and keyboard both worked, so I simply rebooted the computer with the external mouse and keyboard attached, unplugged the external devices, and the built-in keyboard and trackpad worked. About four weeks later, they stopped working again, so I tried my same fix, and it worked again.

    Not sure how long this temp fix will keep working before the logic board goes entirely, but at least for now things are working.
     

Share This Page