MacBook Pro (Late 2011, A1278, Unibody i7) Issues

Discussion in 'MacBook Pro' started by PSaibot, Jun 18, 2016.

  1. PSaibot macrumors newbie

    Joined:
    Jun 18, 2016
    #1
    Hello All,

    I´ve bought yesterday this used (third hand) MacBook Pro.
    It was told to me by the seller that the Mac wont boot up and appears a blinking folder with an ? mark.
    In fact this happens and because the solution is simple and the Mac overall is too good and the low price the seller did i've closed the deal.

    The ? blinking folder can occur due to a corrupted operative system or damaged flat cable, this cable apears to be good, and i've changed de HDD so thers no OSX at all.

    BUT i'm facing some other problems.
    1 - The Mac dont turn's on by pressing the power button
    2 - Some previous Mac's owner have locked the EFI Firmware so i cannot boot into a cd/dvd or USB pen to install the OSX, because é dont know the unlock password.

    Now with some details:

    The Mac's power button dont turn's on the Mac.
    If i unplug and plugin again the battery from motherboard with power cord unplugged, after 5 seconds the Mac starts up automatically without the need of pressing the power button.
    If i unplug the battery from motherboard and plug in the power cord after 5 seconds the Mac starts up in the same conditions.
    If i press the power button for 5 seconds the Mac turns off, so the power button IS working.
    When the Mac starts up the Fan spins always ate hight level.

    I tried all the recommendation on the web and none have worked.

    SMC Reset: Not Worked
    VNRam/PRam Reset: Not Worked
    Press power button for 10 seconds: Not Worked

    I'm running out of ideas...

    Does any one here have had similar problems?
    How to solve the power button issue?
    How to remove the EFI Firmware password?


    Best Regard,
    Pedro
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    You can't. You will need to take it to Apple along with proof of ownership and they can remove it for you using the process described in this article.

    The presence of the firmware lock is often a sign the machine is stolen.
     

Share This Page