MacBook Pro (late 2016) 5Ghz network issue

Discussion in 'MacBook Pro' started by gtal, Jan 9, 2017.

  1. gtal macrumors newbie

    gtal

    Joined:
    Jan 9, 2017
    #1
    MacBook Pro (late 2016) 5Ghz wifi network issue
    I have a two moths old the new 15” MacBook Pro and basically I”m happy with it.

    My main issue is with WiFi networks.

    I have an Airport router with two networks defined (with two different names): a 2.5 Ghz and a 5 Ghz.

    Each time after restart I’m getting connected to the 5 Ghz, however after couple of hours the MacBook switches to the 2.5 Ghz network, and the 5 Ghz network is NOT included in the list (I can’t select it).

    I’m almost sure it’s not a router definition issue, as at the same time, in the same location, all my other Apple devices: MacBook Air, Mac Pro, iPhones, iPads, Apple TVs have both networks as an option. I also didn't face this issue with my previous 4 years old MacBook Pro that has been replaced by this one 2 months ago.

    Until today all my attempts to solve this issue failed.

    My MacBook Pro is a 15-inch, Late 2016, 2.9 GHz Intel Core i7,16 GB 2133 MHz LPDDR3, Intel HD Graphics 530 1536 MB, Sierra 10.12.2
    Any ideas?
     
  2. halfbad macrumors member

    Joined:
    Apr 20, 2014
    #2
    might be a priority issue, If it's not seeing it for whatever reason then it will go to your 2.4 network. In advanced network setting you can set it to prioritize the 5gz over the 2.4ghz. However if it's just not seeing it, there could be an issue there, move closer to the router to see if you computer can even pick it up. If its' not seeing it altogether, I would book an appointment.

    Maybe do all your updates and a SMC/Pram reset as well could help.
     
  3. byakka, Mar 14, 2017
    Last edited: Mar 14, 2017

    byakka macrumors newbie

    byakka

    Joined:
    Mar 14, 2017
    #3
    I've solved the same issue by changing my 5GHz network channel setting from Auto to 48 (20MHz).
     
  4. jerryk macrumors 68020

    Joined:
    Nov 3, 2011
    Location:
    SF Bay Area
    #4
    Are you moving your MacBook from room to room? 5Ghz signals drop off quickly and are blocked by walls, furniture, and any other obstructions. 2.4 Ghz have much better penetration and range, but slow speed and are subject to more interference from other devices.
     
  5. byakka macrumors newbie

    byakka

    Joined:
    Mar 14, 2017
    #5
    That's not the issue here. 5GHz networks just disappear until a reboot, even if you're standing next to the base station.
     
  6. jerryk macrumors 68020

    Joined:
    Nov 3, 2011
    Location:
    SF Bay Area
    #6
    Do you have nearby neighbors that might have used the channel your router selected? Most routers have the ability to detect and adjust the least used channel at boot up. But if you live someplace with enough people nearby, even the 23 channels of 5GHz cannot be enough.

    FWIW, I got rid of all my consumer gear and replaced it with Ubiquiti Access points and dedicated routers. They let me roam throughout my house and yard, and automatically switch devices to the best access point.
     
  7. byakka macrumors newbie

    byakka

    Joined:
    Mar 14, 2017
    #7
    I'm using Ubiquiti gear as well. Did an RF scan and the channel it was using when I observed the issue showed up as barely used. I'm pretty sure that's an issue with the recent macOS since I noticed it with two different models of MBP and none of my other devices have it.
     
  8. jerryk macrumors 68020

    Joined:
    Nov 3, 2011
    Location:
    SF Bay Area
    #8
    Seems strange. My MBPs have no issue. However, I do have 2015 and earlier MBPs, not 2016.
     
  9. byakka macrumors newbie

    byakka

    Joined:
    Mar 14, 2017
    #9
    I've seen that happen on a 2015 mbp with 10.12.2 and on a 2016 one with 10.12.3, probably not a hardware issue.
     
  10. jerryk macrumors 68020

    Joined:
    Nov 3, 2011
    Location:
    SF Bay Area
    #10
    Well something is different. My machines have been solid in my environment.

    Might be because there are only two neighbor's I see, sometimes, on the Wifi list. Other than that both the 2.4 and 5ghz at my house are pretty unused.
     
  11. Arabeek macrumors newbie

    Arabeek

    Joined:
    Jun 15, 2017
    #11
    I've got the same issue with my Mid 2015 Macbook Pro, it's only been recently doing this.

     
  12. gtal thread starter macrumors newbie

    gtal

    Joined:
    Jan 9, 2017
    #12
    enter the wireless options in the "Airport utility App" in UTILITIES and change the 5G channel to 41 or 44...
    This fixed the problem for me.
     

Share This Page