MacBook Pro Loses Internet Connection When Using HDMI Output

Discussion in 'MacBook Pro' started by zjaffe, Jul 6, 2010.

  1. zjaffe macrumors newbie

    Joined:
    Jul 6, 2010
    #1
    Hey all, I've had my 13" MacBook Pro for almost a year now with no problems, until recently. I just bought a new LED HD TV and a HDMI cable and mini-video port adapter so that I can use my TV as a monitor, which in and of itself looks and works great. However, for some strange reason whenever the computer is plugged into the TV, the internet connection I have simply will not work. My Airport shows full connectivity yet no websites will load thus making me not able to watch streaming video online which was the entire point of me buying all this stuff in the first place. And as soon as I unplug the cable, the internet works again. Has anyone else had this problem? It seems very unusual, but hopefully someone has dealt with it previously. Thanks for any suggestions.
     
  2. ColinM macrumors member

    Joined:
    Jan 25, 2008
    Location:
    Pennsylvania
    #2
    The area that you plug the HDMI cord into the Dongle, try wrapping Aluminum foil around the bottom of the HDMI cord, and the top of the dongle.
     
  3. zjaffe thread starter macrumors newbie

    Joined:
    Jul 6, 2010
    #3
    Tinfoil? Really? Amazing that a $1300 piece of technology could be fixed with tinfoil. So amazing in fact that it didn't work :( Could it be an issue with the adapter/hdmi cable, or is it more likely something internal, having to do with my Airport?
     
  4. MacModMachine macrumors 68020

    MacModMachine

    Joined:
    Apr 3, 2009
    Location:
    Canada
    #4
    im not sure why tinfoil was suggested....maybe trying to block some type of interference...

    there is a issue with the logic board or adapter.

    i would have it looked at and repaired.
     
  5. JonB3Z macrumors 6502

    Joined:
    Jun 23, 2009
    #5
    I think the point ColinM was making was that the HDMI cable may be radiating a signal that interferes with your Airport. Which is possible. The tinfoil probably wouldn't help much in that case; you would need a full shield and/or ferrite beads around the cable. Of course, a quality HDMI cable would already have those.

    Depending on how your system is set up, I'd try:

    1) Using an Ethernet cable to connect the MBP to the router
    2) Moving the access point right next to the MBP
    3) Changing the WiFi channel being used

    Of course, it may not be interference at all. If none of that works, probably time to take the MBP to Apple.
     
  6. ColinM macrumors member

    Joined:
    Jan 25, 2008
    Location:
    Pennsylvania
    #6
    Just one thing. When you plug the dongle in without the HDMI cord attached, does the problem happen?
     
  7. nhinja macrumors newbie

    Joined:
    Nov 26, 2011
    #7
    Work-around

    I just recently had the exact same issue. I had a feeling it was because of the encryption for my wireless. I was still using WEP because I was still using old wireless B game adapters to connect my xbox and ps2 wirelessly to the net. Anyway, you have 2 options. Update your encryption to WPA/WPA2 or else run no encryption at all.
     

Share This Page