MacBook Pro (mid 2009) not responding when opening programs

Discussion in 'MacBook Pro' started by Artmuzz, Apr 9, 2013.

  1. Artmuzz, Apr 9, 2013
    Last edited: Apr 9, 2013

    Artmuzz macrumors 6502

    Joined:
    Jun 17, 2008
    #1
    I have an old MacBook Pro aluminium unibody but I have started having problems with it. I haven't been using the machine for over a year but last night switched it on to use. It was running well until today when it is running sluggish. When I try to open program's or folders the coloured spinning wheel appears and spins for for a long time. I have tried switching it off form the power button and rebooting but I still get the same problem. I have tried selecting "force quit" but I cannot do that without the spinning wheel spinning for ages. I am running Snow Leopard 10.6.8.

    Please advise

    EDIT - pressing alt, command and esc keys together for a few seconds seems to help but unfortunately it goes back to the spinning wheel when trying access folders or programs.

    Could this be a problem with the RAM memory in my MacBook Pro?
     
  2. Artmuzz thread starter macrumors 6502

    Joined:
    Jun 17, 2008
    #2
    I wish someone would help me here:mad:

    I have rebooted my MacBook Pro with the recovery DVD and selected disk utility. When I go to repair disk after a while trying to repair disk it gives me an error of Invalid node structure then it gives me a bunch of errors and doesn't repair disk:( It then finishes repair telling me that disk utility can't repair this disk and to back up files and reformat.

    I fear that my MacBook Pro could be visiting the scrap yard soon. Someone please help.
     
  3. B... macrumors 68000

    B...

    Joined:
    Mar 7, 2013
    #3
  4. Artmuzz thread starter macrumors 6502

    Joined:
    Jun 17, 2008
    #4
    I am using the standard 4GB ram which I thought was enough to run Snow Leopard.
     
  5. Artmuzz thread starter macrumors 6502

    Joined:
    Jun 17, 2008
    #5
    Okay, I ran disk utility again and it seemed to of repaired the disk. I booted back onto Snow Leopard and it seems to work as normal now. However I have a feeling it will start acting sluggish again. If that happens I will try the setting on the link that you supplied.
     

Share This Page