Macbook Pro mid 2012 shift function always on power button not working

Discussion in 'MacBook Pro' started by foxes71, Oct 8, 2015.

  1. foxes71 macrumors newbie

    Joined:
    Oct 8, 2015
    #1
    Hi,

    Have tried to find an article or thread that discusses my issue but can't find an exact match.

    MacBook Pro mid 2012 13" i5 8GB 1TB (A1278) OS X Yosemite 10.10.5 - Out of Warranty. Unit is an older model but actually purchased August 2013.

    After a spill (water), keyboard inputs started to behave erratically (unsurprising). Initial steps :-

    1) Removed bottom cover and dried some minor moisture.
    2) Applied isopropyl through the top case to drive out any moisture remaining between the keyboard keys and the backlight membrane.
    3) With the bottom cover open, left the MBP to dry out for four days.

    After the drying out period, all keyboard inputs returned to normal, with a couple of exceptions . Shift is permanently activated and the Power button does not respond. (I do realise that the power button is attached to the keyboard) Symptoms are as expected :-
    • Boots into safe mode - circumvented by holding down Option key.
    • All keyboard letter displayed in capitals. Number keys display their shift characters only.
    • Some functions key work, some don't.
    • Some track pad functions impacted due to shift activated (two finger tap works in some contexts, not others).
    • Due to power button inoperable, have to power on by disconnecting the battery and powering up directly from the mains (pain in the arse as it involves removing the bottom cover each time).
    • USB keyboard works perfectly. USB mouse also works around lack of some right click functions.
    • Keyboard viewer does NOT show shift keys activated. However, inputting via Keyboard viewer results in the same problems i.e. results in letters in caps and number shift characters.
    After a lot of checks and reading articles on the internet, I convinced myself that it must be a hardware issue(s) with the keyboard. So, sourced and replaced a new keyboard, a time consuming, tricky job. The original keyboard did have signs of dirt and residue build up but nothing obviously 'broken'. Once rebuilt, I found that the power button still didn't work and that once I'd rebooted, the keyboard inputs were precisely the same. Not what I was expecting.

    Any ideas..? Logically, seems like next step is to replace the logic board but that's an expensive step without any particular confidence that this will resolve the issue. Are there any checks or troubleshooting steps that I've missed and/or should try before replacing the logic board..?

    Thanks in advance,

    foxes71

    MacBook Pro, OS X Yosemite (10.10.5)
     
  2. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #2
    Swapping the logicboard implies swapping pretty much everything inside the computer. It would resolve your issue.
     
  3. foxes71 thread starter macrumors newbie

    Joined:
    Oct 8, 2015
    #3
    Agreed. I suspect it would.

    New news.

    Was playing last night, multiple hard reboots - disconnecting battery and powering up from the mains / magsafe. Through some sequence of power plus key presses, managed to reset NVRAM (PRAM). I hadn't been able to achieve this previously. Anyway, it did the trick ! Logged back in and the shift key issue was resolved. But.. power button wouldn't work so I continued to work on it. Tried multiple times for an SMC reset without success. Power button not responding to SHIFT+CTRL+OPT+Power. Long story short, after a number of reboots, the shift problem came back...

    So I'm back to square one. Can't reset NVRAM - can't get second chime - just continues booting up regardless of ALT+OPT+P+R.

    The fact that I resolved part of the issue and then it returned is pointing me back to hardware i.e. some problem with the NVRAM chip and/or the SMC chip.

    Thoughts..?
     
  4. foxes71 thread starter macrumors newbie

    Joined:
    Oct 8, 2015
    #4
    Right - getting somewhere.

    If I log in, then flash the NVRAM with the terminal with nvram -c the shift becomes 'unstuck'. If I then use the keyboard viewer to type, it functions correctly. But, as soon as I type on the keyboard, shift functionality is locked back in.

    So, I'm back to some issue with the logic board. Possibly a short or corrosion of some kind causing the NVRAM and/or the SMC chip to act erratically.
     

Share This Page