MacBook Pro mid 2012 won't restart or shutdown

Discussion in 'MacBook Pro' started by solidsn2004, Sep 2, 2016.

  1. solidsn2004 macrumors newbie

    Joined:
    Oct 30, 2014
    Location:
    Milan
    #1
    Hi guys,

    I don't know if I am supposed to post this thread here or under Mac OS X. I have a mid 2012 MBP non retina. It's been like a month that I noticed that it doesn't restart or shutdown and I have to force it to shutdown by pressing the power button.

    Now that there is the security update and I need to restart my MBP in order to install it I can't do it. Basically when I try to restart, desktop icons disappear and the mac stays on with the dock and the background on my display. It's not frozen as I can open applications from the dock normally.

    It's been like 6 months since I have installed a Samsung EVO 850 1TB ssd instead of the original HD and I don't know if it has something to do with this or if it's a software issue.

    I tried reseting PRAM and verified disk permissions but nothing works. I also started in safe mode but problem persists.

    Is there a way to figure out what causes this issue?
    Thanks in advance.
     
  2. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #2
    Probably a software issue.

    If you start in verbose mode then an attempt to shut down should be similarly verbose, although from what you describe (the desktop etc. persisting) it'll not get as far as the verbosity.

    Whilst the Mac was in safe mode, did it also fail to shut down?

    A Console view of all messages might help you to identify the causes.
     
  3. solidsn2004 thread starter macrumors newbie

    Joined:
    Oct 30, 2014
    Location:
    Milan
    #3
    Thanks for your reply grahamperrin. Mac won't restart after verbose mode. However, in safe mode I can restart it with no problem.
    I am not really familiar with Console view. Could you guide me on what exactly to do in order to find issues inside console's log file? Do I need to post anything here? log file is really big so I don't know from what point I need to start looking for an issue.
    Thanks again.
    --- Post Merged, Sep 2, 2016 ---
    Ok I have managed to install the latest update by entering safe mode and while restarting it installed it. However, it still gets stuck when trying to reboot or shutdown...
    --- Post Merged, Sep 2, 2016 ---
    Ok I cleared console log and restarted my mac. Every 10 seconds my log file shows the following:

    02/09/2016 23:18:10.733 TOCGenerator[721]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.6 instead of 10.11.6. This is not a bug in Gestalt -- it is a documented limitation. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
    Call location:
    02/09/2016 23:18:10.733 TOCGenerator[721]: 0 CarbonCore 0x9140de3d ___Gestalt_SystemVersion_block_invoke + 135
    02/09/2016 23:18:10.733 TOCGenerator[721]: 1 libdispatch.dylib 0x9d89e83f _dispatch_client_callout + 50
    02/09/2016 23:18:10.733 TOCGenerator[721]: 2 libdispatch.dylib 0x9d89e71b dispatch_once_f + 78
    02/09/2016 23:18:10.733 TOCGenerator[721]: 3 libdispatch.dylib 0x9d89ffa5 dispatch_once + 31
    02/09/2016 23:18:10.733 TOCGenerator[721]: 4 CarbonCore 0x913898e1 _Gestalt_SystemVersion + 1047
    02/09/2016 23:18:10.733 TOCGenerator[721]: 5 CarbonCore 0x9138908a Gestalt + 154
    02/09/2016 23:18:10.733 TOCGenerator[721]: 6 TOCGenerator 0x000023da -[AppDelegate applicationDidFinishLaunching:] + 28​

    Then I went exactly on the second that I clicked to restart my mac and I only have this in the log file:

    02/09/2016 23:18:41.684 com.apple.xpc.launchd[1]: (com.hp.help.tocgenerator) Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
    02/09/2016 23:19:26.000 bootlog[0]: BOOT_TIME 1472851166 0​

    And then there is a bunch of those:

    02/09/2016 23:19:28.000 syslogd[47]: Configuration Notice:
    ASL Module "com.apple.AccountPolicyHelper" claims selected messages.
    Those messages may not appear in standard system log files or in the ASL database.​
     
  4. grahamperrin, Sep 3, 2016
    Last edited: Sep 3, 2016

    grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #4
    Be prepared to enter your admin password then in a Terminal window, enter these two commands:

    sudo launchctl list | grep -v com.apple

    sudo kextstat | grep -v com.apple


    If you paste the outputs to this topic then someone may recognise an item of software that's known to cause trouble.
     
  5. solidsn2004 thread starter macrumors newbie

    Joined:
    Oct 30, 2014
    Location:
    Milan
    #5
    Thanks again for your reply. Here are the results:

    PID Status Label

    77 0 com.rim.BBDaemon

    - 0 com.parallels.mobile.kextloader.launchdaemon

    - 0 com.quark.quarkupdate

    - 71 com.paceap.pacesupport

    - 0 org.postfix.master

    - 0 net.freemacsoft.LiteIcon.LIHelperTool

    - 0 com.adobe.ARMDC.Communicator

    89 0 com.parallels.mobile.dispatcher.launchdaemon

    111 0 com.dymo.pnpd

    - 0 com.malwarebytes.HelperTool

    224 0 org.cups.cupsd

    - 0 org.postfix.newaliases

    - 0 com.openssh.sshd

    - 0 org.wireshark.ChmodBPF

    - 78 org.opensc.pcscd.autostart

    - 0 com.microsoft.office.licensing.helper

    - 0 com.rogueamoeba.instanton-agent

    - 0 com.google.keystone.daemon

    78 0 Adobe_Genuine_Software_Integrity_Service

    83 0 com.trusteer.rooks.rooksd

    - 0 com.oracle.java.Helper-Tool

    - 0 com.quark.QXPHelper

    - 0 org.cups.cups-lpd

    225 0 com.vix.cron

    - 0 com.autodesk.backburner_start

    - 133 com.autodesk.backburner_server

    - 0 com.quark.quarkupdate.quhelper

    - 0 com.adobe.SwitchBoard

    - -5 com.autodesk.backburner_manager

    - 0 com.logmein.raupdate

    - 0 com.sharpcast.xfsmond

    - 0 com.adobe.fpsaud

    - 0 com.adobe.ARMDC.SMJobBlessHelper

    223 0 org.ntp.ntpd

    - 0 org.macosforge.xquartz.privileged_startx

    - 0 com.teamviewer.Helper

    Index Refs Address Size Wired Name (Version) UUID <Linked Against>

    22 0 0xffffff7f81114000 0x18000 0x18000 com.rim.driver.BlackBerryUSBDriverInt (0.0.67) 3D68C30B-05F8-FB91-8606-B0F892DAA206 <21 20 19 18 16 5 4 3 1>

    139 0 0xffffff7f8115a000 0x5000 0x5000 com.logmein.driver.LogMeInSoundDriver (4.1.50f15) 9F652285-686E-36E5-B460-A33155E7529A <113 5 4 3>

    141 0 0xffffff7f80eb3000 0x5000 0x5000 net.telestream.driver.TelestreamAudio (1.0.5) EB0437EB-B4CD-CD8B-6306-C62D4459540C <113 5 4 3 1>

    143 0 0xffffff7f82d1f000 0x7000 0x7000 com.parallels.virtualsound (1.0.36 36) E9131806-D073-8482-AC46-B4AAE55EA6FE <113 5 4 3 1>

    149 0 0xffffff7f80de7000 0x6000 0x6000 com.quark.driver.Tether64 (1.1.0d3) 49842400-0932-74D9-89AB-1F3F9442373E <55 5 4 3 1>

    156 0 0xffffff7f82f26000 0x5000 0x5000 com.parallels.virtualhid (1.0.3 3) B0C355DF-4268-359B-9654-0A67F4305F7B <41 5 4 3 1>​
     
  6. solidsn2004 thread starter macrumors newbie

    Joined:
    Oct 30, 2014
    Location:
    Milan
    #6
    Anyone?

    I am also noticing another issue. If I open network diagnostics and then close it the icon stays in the dock even if I try and force quit it. The only way to get rid of it is either force quit macbook and start it over or if I type in terminal:

    sudo killall launchservicesd

    Is there anyone who can help me resolve this?
     

Share This Page