MacBook Pro No System Sounds on External Speakers

Discussion in 'MacBook Pro' started by msalerno1, May 4, 2012.

  1. msalerno1 macrumors newbie

    Joined:
    May 4, 2012
    #1
    Here's a strange one...

    I have a MacBook Pro running OSX Lion (10.7.3). Recently, I have noticed that it will occasionally stop making system sounds through my external speakers.

    Playback from iTunes, etc. seems to work fine.

    Now, here's the strange part. When I unplugged my external speakers to plug in my ear buds to make a conference call via WebEx my computer suddenly started playing ALL of the systems sounds that had been saved up. As my machine had been on for several days, this playback took about 5 minutes of bings, bongs, and swooshes.

    This same behavior happened again today. I noticed that the system sounds had stopped so I unplugged my external speakers and my machine made all the sounds from the past several hours through the internal speakers.

    Any ideas on what's going here?

    Thanks!
     
  2. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #2
    I haven't heard of this before, but to start looking at what could be wrong, have you:

    • Restarted the computer
    • Checked for and installed all software updates
    • Ensured all physical connections are seated properly
    • What version of MBP do you have?
    • How are these external speakers connecting? Are they using the stereo jack or USB connection?
      Have you looked in Console for any errors related to sound or speakers?
     

Share This Page