MacBook Pro not booting up ? folder logo

Discussion in 'MacBook Pro' started by albri98, Jan 7, 2015.

  1. albri98 macrumors newbie

    Joined:
    Feb 17, 2011
    #1
    i have a late 2012 MacBook Pro with updated OS X Yosemite,

    i was using the laptop and everything froze. i restarted it. then when the laptop turned on a folder with a question mark displayed in stead of the apple logo. I tried reinstalling Yosemite(usb bootdisk) however when it asked to choose a hard drive the MacintoshHD was not displayed. I took the my hard drive out of my mac and put in an other mac, the hard rive booted up fine with no issues. I took the other macs hard drive and it also booted up fine. so the hard drive cable nor the hard drive are defective. after several time of unpluging the hard drive and plugin it back it it magically worked. i used the computer for 3 days and everything happened again the computer froze and once i restarted it the same log came up.
    HELP!!
     
  2. thewap macrumors demi-god

    thewap

    Joined:
    Jun 19, 2012
    #2
    disc utility check? - check if the HD is corrupted or failing. Trying it on other comps might not have revealed an underlying problem as you didn't leave the HD in them as long as the original comp.
     
  3. albri98, Jan 8, 2015
    Last edited: Jan 8, 2015

    albri98 thread starter macrumors newbie

    Joined:
    Feb 17, 2011
    #3
    First thank for the reply.
    However I can't check the hard drive because it is not displayed in disk utility, is like i don't have a hard drive plugged in.
     
  4. cjmillsnun macrumors 68020

    Joined:
    Aug 28, 2009
    #4
    thewap is referring to the internal HD (or SSD if it is a rMBP). All Macs and PCs have some sort of drive that they boot from. This is either a hard drive or SSD and is inside the computer itself.

    It sounds like this has failed.

    The folder with a question mark indicates that the computer cannot find an operating system.

    EDIT: just re-read the initial post.

    It could be the SATA cable that has failed.
     
  5. albri98 thread starter macrumors newbie

    Joined:
    Feb 17, 2011
    #5
    Thanks for the post.
    That was my first thought, however when i plugged in another HD into this mac the computer booted up fine.
     
  6. KUguardgrl13 macrumors 68020

    KUguardgrl13

    Joined:
    May 16, 2013
    Location:
    Kansas, USA
    #6
    I'd suspect the SATA cable. They're notorious for failing in the cMBPs (which it sounds like this one is if you can take the hard drive out easily and put it in a different Mac).

    If you have AppleCare on your Mac, this would be a time to take it in and get it checked out. Unfortunately in my experience this is a recurring problem. In my case they kept replacing the cable and HD in my 2009 MBP even after my Apple Care had expired.
     
  7. albri98 thread starter macrumors newbie

    Joined:
    Feb 17, 2011
    #7
    thanks for the reply.
    i do not have apple care :/ but i will order a new to try it out, very very essay to replace compare to an iPhone screen replacement.

    thanks again.
     

Share This Page