MacBook Pro not displaying time correctly

carlili4190

macrumors regular
Original poster
Jun 8, 2010
125
0
Hey guys. I bought a samsung 840 evo 750gb around Christmas and absolutely love it. Everything is perfect. I'm getting write speeds of 450+ and read speeds of 500+ mb/s. Boot time is insanely fast too.

However, I've had one problem ever since I installed the ssd and it's finally starting to bug me and I have no idea how to fix it.
When I installed the ssd it was a fresh install. Everything was put on new and nothing was restored from a backup. (Just some background info)
Now my problem is the time. Whenever my computer backs up or has to report the time such as when a file is created or modified it only shows "today, 3: pm". It doesn't show the minutes! On the menu bar it shows the minutes. In the settings it is set to " set time and date automatically: Apple Americas/US(time.apple.com)
And the time zone is set to automatic so I have no clue what is wrong. This also never happend when I had the hdd in so I really don't know what to do. It's getting quite annoying honestly. Any help would be greatly appreciated.

Does anyone have a clue as to why it wouldn't display the minutes and only the hour?
 

BigBeast

macrumors 6502a
Mar 6, 2009
642
40
I'm not sure where the problem originates, but we can try other options if this doesn't work.

Go to: Apple Menu > System Preferences > Language & Region > Advanced > Times

I've attached a screenshot of what my format looks like. Do your options look any different? If so, Change them to what they look like in my screenshot.
 

Attachments

carlili4190

macrumors regular
Original poster
Jun 8, 2010
125
0
I'm not sure where the problem originates, but we can try other options if this doesn't work.

Go to: Apple Menu > System Preferences > Language & Region > Advanced > Times

I've attached a screenshot of what my format looks like. Do your options look any different? If so, Change them to what they look like in my screenshot.
I've tried to do that but like on yours, my restore default button is greyed out. Otherwise mine looks exactly the same. I still haven't been able to find a solution. I'll try to post a screenshot of it later today.
 

chmodme

macrumors member
Oct 19, 2012
78
1
perhaps

Something as simplistic as booting off of another drive/stick/disk/partition and doing a disk repair, in particular permissions?

Worth a shot.

Or, login as root and see what it looks like? That would pretty much confirm it is permission-based.
 

carlili4190

macrumors regular
Original poster
Jun 8, 2010
125
0
Something as simplistic as booting off of another drive/stick/disk/partition and doing a disk repair, in particular permissions?

Worth a shot.

Or, login as root and see what it looks like? That would pretty much confirm it is permission-based.
I regularly boot into windows for bootcamp so I don't think that's the problem. I have verified and repaired permissions in both osx and the recovery partition. How does one login as root? And check?
 

carlili4190

macrumors regular
Original poster
Jun 8, 2010
125
0
I'm not sure where the problem originates, but we can try other options if this doesn't work.

Go to: Apple Menu > System Preferences > Language & Region > Advanced > Times

I've attached a screenshot of what my format looks like. Do your options look any different? If so, Change them to what they look like in my screenshot.
Omg. You know what. I overlooked this. The minute portion wasn't in there. WOWWOWOWOWO. Thank you thank you thank you!!!!