MacBook Pro not getting IP address via DHCP

Discussion in 'Mac OS X Lion (10.7)' started by kenchie, May 13, 2014.

  1. kenchie macrumors newbie

    kenchie

    Joined:
    Apr 26, 2011
    Location:
    London
    #1
    I have an early 2008 MBP running Lion 10.7.5. on a corporate LAN. Recently it has refused to pick up IP addresses via DHCP on both the ethernet and wifi interfaces. I have tried the following without success;

    1. New network location
    2. Different ethernet connection via USB adaptor
    3. Trashing keychain entries for corporate network
    4. Trashing network prefs plist files
    5. Reset PRAM
    6. New user account

    None of the above made any difference, it just defaults to a 169.254 IP address and not the 10.128 range that the network requires.

    If I enter recovery mode, the ethernet works fine and can access the internet.

    Any ideas please?

    Thanks.
     
  2. Bruno09, May 13, 2014
    Last edited: May 13, 2014

    Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Hi,

    Some ideas :

    1. repair the permissions using Disk Utility, then test the connexion

    2. boot in safe mode (Shift key), test the connexion

    3. trash the whole Macintosh HD/Library/Preferences/SystemConfiguration folder, then reboot.
     
  3. kenchie thread starter macrumors newbie

    kenchie

    Joined:
    Apr 26, 2011
    Location:
    London
    #3
    Thanks very much, this worked!
     
  4. gdt95 macrumors newbie

    gdt95

    Joined:
    Aug 14, 2015

Share This Page