Macbook pro not recognizing Iomega external harddrive

Discussion in 'MacBook Pro' started by Hreyo25, Nov 21, 2009.

  1. Hreyo25 macrumors newbie

    Joined:
    Nov 21, 2009
    #1
    Hi this is my first post so dont go to hard on me.

    I have a Iomega external hard drive and it was working great until two days i must have unplugged the usb before i ejected it and now my macbook pro cant recognize it. In disk utility I saw the hard-drive but it would not let me format it. I dont know what to do if anyone could help me I would greatly appreciate it.
    Thanks
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    What MacBook Pro, what Mac OS X version and what specific Iomega model are you using?

    What error message does Disk Utility give you?

    Have you tried the Erase Tab of Disk Utility?
     
  3. Hreyo25 thread starter macrumors newbie

    Joined:
    Nov 21, 2009
    #3
    I have the late june 2009 unibody 2.8 macbook pro running leopard 10.5.8.

    I have Iomega Prestige 500 GB USB 2.0 Desktop External Hard Drive

    When i click erase it says that an unknown error has occurred. This happens every time I have tried to erase it. Now disk utility is not even recognizing it.
     
  4. Hreyo25 thread starter macrumors newbie

    Joined:
    Nov 21, 2009
  5. Hreyo25 thread starter macrumors newbie

    Joined:
    Nov 21, 2009
  6. fluffyx macrumors 6502

    Joined:
    Oct 25, 2007
    #6
    To be thorough, you may wish to try the hard drive on a different computer.

    It's possible that the drive won't work on any computer, in which case, I'd contact Iomega about warranty service.
     

Share This Page